InfluxDB ADmin UI

#1

Hi Jack, i know this is mentioned in the website but im a bit confused on web interface of Influxdb version 1.2.2.

Is the web admin UI completely removed from 1.2 and more or do i need to enable the admin section to true and set environment variables to enable influxdb and port as mentioned in website? i still ttried to enable the admin section inf conf file and also provided the enrvironment variable but still not reachable to web UI?

#2

@Praphooldhole Can you share the relevant sections of the config file? Also you will need to restart the process for those changes to take affect.

#3

Yess i did restart the process still the changes did not take place.

[admin]
#Determines whether the admin service is enabled.
enabled = true

The default bind address used by the admin service.

bind-address = “:8083”

Whether the admin service should use HTTPS.

https-enabled = false

The SSL certificate used when HTTPS is enabled.

https-certificate = “/etc/ssl/influxdb.pem”

#4

Yess i did restart the process still the changes did not take place.

[admin]
#Determines whether the admin service is enabled.
enabled = true

#5

@Praphooldhole the config looks correct. How are you trying to connect, and what error are you seeing?

#6

so im trying to reach on 10.X.X.X:8083 i get this error :
Exception: tcp_error
Exception details: A communication error occurred: "Connection refused"
Requested URL: http://10.205.76.136:8083/

#7

When you run curl -i http://10.205.76.136:8086/ping what output do you see?

#8

i ran the said command and see the output:

TTP/1.1 403 Target service not allowed
Date: Fri, 26 May 2017 16:16:48 GMT
Cache-Control: no-cache
Pragma: no-cache
Content-Type: text/html; charset="UTF-8"
Content-Length: 2521
Accept-Ranges: none
Proxy-Connection: close
ALSO THIS IS WHEN I RUN IT FROM INSIDE THE INFLUX DOCKER CONTAINER:
root@88e8898c2fc7:/# curl -i http://10.205.76.136:8086/ping
HTTP/1.1 204 No Content
Content-Type: application/json
Request-Id: 23f150b2-422f-11e7-8001-000000000000
X-Influxdb-Version: 1.2.2
Date: Fri, 26 May 2017 16:19:49 GMT
Proxy-Connection: Keep-Alive
Connection: Keep-Alive

#9

InfluxDB is configured correctly. I don’t follow how your network is configured, but it looks like there’s a firewall or something blocking access to InfluxDB.