Unable to activate authentication: auth-enabled = true not working

Hi, I have followed instructions from:
https://docs.influxdata.com/influxdb/v1.7/administration/authentication_and_authorization/

Created two users admin/admin and user01/user01 as follow:
CREATE USER “admin” WITH PASSWORD ‘admin’ WITH ALL PRIVILEGES

sudo nano /etc/influxdb/influxdb.conf
auth-enabled = true (uncommented), saved
sudo reboot

But still can post and read data from influxDB with wrong credentials and no credentials at all.

Assistance welcome.
Paulo

If you run SHOW USERS, do you see the accounts listed?

Hi,

show users
user admin
admin true
user01 true

Okay. Can you walk me through the process you’re using after restarting the service?

Are you just restarting and then sending a request?

After I create the users and edit /etc/influxdb/influxdb.conf I just reboot the server.

To test I am using node-red
I set wrong username at node-red and expect it to fail but it keeps working.

Hi Katy, any other suggestion?
Thanks

I’m looking into some other things it can be. I’ll keep you updated!

Hi Katy.
Thanks
Paulo

One more thing to try:

It seems that the http line in the config has to uncommented as well.

So your config should look like this:

[http]
  # Determines whether HTTP endpoint is enabled.
   enabled = true

and NOT like

#[http]
  # Determines whether HTTP endpoint is enabled.
   enabled = true

Great, will try and report back.
Thanks

Dear Katy,
Just did the test and it is working great.

One note:
First I did uncomment the line
[http] and
auth-enabled = xxxx and then it did not work…
What a frustration…
What to do now?

But then I started to review the whole thing, and found that the line on the /etc/influxdb/influxdb.conf was originally:
auth-enabled = false

So one has to umcomment it and somehow see that it is not enough, one still have to see it should be changed to:
auth-enabled = true

Now it is working great,
Thanks a lot for your support

Paulo