InfluxDB 1.3.7 issue enabling http authentication on Windows

influxdb
#1

I’ve been trying to setup InfluxDB for a while now and I just cannot figure out how to get authentication to enable. The documentation makes it seem like this should be pretty easy but so far all attempts have failed. Below are the steps I’ve followed.

I’ve downloaded a fresh version of influxDB
Then I create a admin user with the command CREATE USER WITH PASSWORD ‘’ WITH ALL PRIVILEGES
I open the config file and change the [http] section to as follows
[http] enabled = true
bind-address = ":8086"
auth-enabled = true # :sparkles:
log-enabled = true
write-tracing = false
pprof-enabled = false
https-enabled = false
https-certificate = “/etc/ssl/influxdb.pem”

Then after restarting InfluxDB the console shows “Authentication enabled:false service=httpd” and authentication does not work.

Any help would be appreciated, thanks for your time.

#2

Issue has been resolved: https://github.com/influxdata/influxdb/issues/9113