InfluxDB 1.7.9 issue enabling http authentication on Windows, influxdb.pem: The system cannot find the path specified

I am unable to use influxdb in windows 10 machine.

I’ve downloaded a fresh version of influxDB 1.7.9.
Then I create a admin user with the command CREATE USER WITH PASSWORD ‘’ WITH ALL PRIVILEGES
I open the config file and change the [http] section to as follows
[http] enabled = true
bind-address = “:8086”
auth-enabled = true # :sparkles:
log-enabled = true
write-tracing = false
pprof-enabled = false
https-enabled = false
https-certificate = “/etc/ssl/influxdb.pem”

Then after restarting InfluxDB the console as “influxd.exe -config influxdb.conf”, auth shows ture however it is getting terminated with below issue:
2019-11-11T17:57:04.694815Z info Auth is enabled but shared-secret is blank. BearerAuthentication is disabled. {“log_id”: “0J2udAHl000”, “service”: “httpd”}
run: open server: open service: open /etc/ssl/influxdb.pem: The system cannot find the path specified.

Gone through the link https://github.com/influxdata/influxdb/issues/9113. but here the issue was not passing -config in the command. Though I am launching to read the latest conf file, facing the above issue.

Please guide.

Hi @laksh and welcome to the community!

First off, if this is truly running on Windows, the path to the https-certificate should be a windows path, something like C:\Program Files\wher\my\cert\is and not a UNIX path. It also looks like from the snipet you posted that the https-enabled = false will prevent using https anyway.

Can you verify these things?

dg

Thanks for the reply and guidance. https-enabled = false is set to ‘true’. Do I need to have this certificate created on my own and give reference path in config file?
We are trying to setup Jmeter with Grafana integrating InfluxDb.

You will need a valid SSL Cert, and to give the actual path to the actual cert in the config file. You can use a self-signed cert, but the cert must be valid, and must be at the location you specify. The path in default config file is just an example path and is not meat to imply that there is a valid cert there. There are lots of articles on how to create a self-signed SSL Cert, but this one might be helpful: https://www.sslshopper.com/article-how-to-create-a-self-signed-certificate-in-iis-7.html

dg