Chronograf connection to Kapacitor


I having problems connecting my instance of Chronograf to the Kapacitor after upgrade the Chronograf version. I’m using the Chronograf (1.7.2) and Kapacitor (1.5.1) docker images to run the applications and my InfluxDB instance run on the host.

I continue to receive alerts in my Slack channel from the Kapacitor, and see the Alerts - Last 30 days in the Chronograf home page. But, when I’m going to the Kapacitor connection I’m seeing the following message: “Could not connect to Kapacitor. Check your connection settings in the Configuration page”.

I’m seeing that the ping request to the Kapacitor returns 502. In the Kapacitor the hostname is ‘kapacitor’ and my kapacitor URL is http://kapacitor:9092.

Can anybody helps me with this issue?

Thanks in advance.

Hi , maybe a silly question but … is Kapacitor running fine ?

Definitively when I execute the following command in the Kapacitor: kapacitor -url http://kapacitor:9092 list tasks

I’m having the following error: ‘Get http://kapacitor:9092/kapacitor/v1/tasks?dot-view=attributes&fields=type&fields=status&fields=executing&fields=dbrps&limit=100&offset=0&pattern=&replay-id=&script-format=formatted: dial tcp connect: connection refused’

I can’t help thinking that your kapacitor is down or in a bad state , if possible can you stop/start kapacitor ?

I already did a docker restart to the container and already have created a new docker container.

Hi I can reproduce the same error when I stop my kapacitor …
can you chek the kapacitor log file for errors ?

kapacitor -url http://localhost:9092 list tasks
ID Type Status Executing Databases and Retention Policies
cpu_alert_stream stream enabled true [“telegraf”.“autogen”]

systemctl stop kapacitor

kapacitor -url http://localhost:9092 list tasks
Get http://localhost:9092/kapacitor/v1/tasks?dot-view=attributes&fields=type&fields=status&fields=executing&fields=dbrps&limit=100&offset=0&pattern=&replay-id=&script-format=formatted: dial tcp [::1]:9092: connect: connection refused

I’ve solved the issue by creating a new docker container for the Kapacitor. I don’t know, probably the database was corrupted after the container restarting?

Glad you fixed it David ,
for some reason the kapacitor was probably down , you can check the logfiles to find out.
Have a nice day