Chronograf cannot connect to Kapacitor

chronograf
kapacitor
#1

I have just installed Chronograf and Kapacitor using APT (https://repos.influxdata.com/ubuntu) on an EC2 instance on Amazon Web Services. Using default configuration for Kapacitor.

Ubuntu 14.04.5 LTS
Chronograf 1.4.2.3-1
Kapacitor 1.4.1-1
Influxdb 1.5.0-1

But Chronograf cannot connect to Kapacitor. In the Chronograf UI I click “Configure Kapacitor” on the start page. I have the Kapacitor URL set to “http://localhost:9092”, leaving username/password blank. When I click the “Connect” button I get this error message :

Could not connect to Kapacitor. Check settings.

From the Kapacitor log;

ts=2018-03-16T13:12:27.650Z lvl=info msg=“kapacitor starting” service=run version=1.4.1 branch=HEAD commit=b05bb0f6be089d6a1a391867ad4020344ce42a53
ts=2018-03-16T13:12:27.650Z lvl=info msg=“go version” service=run version=go1.9.2
ts=2018-03-16T13:12:27.650Z lvl=info msg=“listing Kapacitor hostname” source=srv hostname=localhost
ts=2018-03-16T13:12:27.650Z lvl=info msg=“listing ClusterID and ServerID” source=srv cluster_id=c5a4e717-79b4-4bdb-82ea-d315bc5be8a1 server_id=810b7ee0-cef6-4a79-b672-90e9de6b4d28
ts=2018-03-16T13:12:27.651Z lvl=info msg=“opened task master” service=kapacitor task_master=main
ts=2018-03-16T13:12:27.747Z lvl=info msg=“Starting target manager…” service=scraper
ts=2018-03-16T13:12:27.747Z lvl=info msg=“starting HTTP service” service=http
ts=2018-03-16T13:12:27.747Z lvl=info msg=authentication service=http enabled=false
ts=2018-03-16T13:12:27.747Z lvl=info msg=“listening on” service=http addr=[::]:9092 protocol=http
ts=2018-03-16T13:12:27.748Z lvl=info msg=“listening for signals” service=run
ts=2018-03-16T13:12:30.038Z lvl=info msg=“http request” service=http host=127.0.0.1 username=- start=2018-03-16T13:12:30.018657646Z method=POST uri=/write?consistency=&db=_internal&precision=ns&rp=monitor protocol=HTTP/1.1 status=204 referer=- user-agent=InfluxDBClient request-id=ae50cbdf-291b-11e8-8001-000000000000 duration=19.573805ms

Do I have to do anything more than installing kapacitor?

sudo apt-get install kapacitor

Cheers

#2

No bother, I was surfing to the wrong instance. :smiley: