The deafult influxdb port

Hi, I am monitoring servers with grafana, influxdb and telegraf. But i have problem on some servers because i have a closed port 8086 port there( I can’t open because this is not my servers). From what I understand, I have to change this port in influxdb.conf and i did this. I change bind-address from 8086 to 1521(this port i have open in these servers) but still not working. I changed this port in telegraf.conf in [[outputs.influxdb]] also. Is it a place where should i change this port also? Where should I change this port too?

Hi @Grzegorz ,

what is the result of :

influxd config|grep -i bind

probably you have restarted the influxdb after changing the config ? but to be sure …

best regards

Yes i restared. I use Windows so can’t put this command :confused:

Hi you can share a part of your configfile that contains the bind-address ?
Have you uncommented that line ?

[http]

Determines whether HTTP endpoint is enabled.

enabled = true

Determines whether the Flux query endpoint is enabled.

flux-enabled = false

Determines whether the Flux query logging is enabled.

flux-log-enabled = false

The bind address used by the HTTP service.

bind-address = ":1521"

Determines whether user authentication is enabled over HTTP/HTTPS.

auth-enabled = true

The default realm sent back when issuing a basic auth challenge.

realm = “InfluxDB”

Determines whether HTTP request logging is enabled.

log-enabled = true

Hi can what is the config file you use, the default one for example in
C:\Program Files\influxdb-1.7.4-1 ?

Can you do :

 influxd config |findstr bind

I am using version 1.7.6-1, confing file is influxdb.conf. Can’t run this command, because i have this error: influxd : The term ‘influxd’ is not recognized as the name of a cmdlet, function, script file, or operable program.

Hi ,

if you open a cmd terminal window and navigate to the location where the influxd executable is located the command should work

I have the same error but under this error i have something like this: Suggestion [3,General]: The command influxd was not found, but does exist in the current location. Windows PowerShell do
es not load commands from the current location by default. If you trust this command, instead type: “.\influxd”. See “get-help about_Command_Precedence” for more details.

Okey, I run cmd as admin and have something like this:
bind-address = “127.0.0.1:8088”
bind-address = “:8086”
bind-socket = “/var/run/influxdb.sock”
bind-address = “:2003”
bind-address = “:25826”
bind-address = “:4242”
bind-address = “:8089”

it means that port 1521 is not configured properly … it is still 8086 ( the default )

I don’t know why this is happend, i saved this file and then restarted influxdb

Hi please check this out , Antoine has written a very good post about it …
especially configuring a service on windows may be handy

still don’t know why this file don’t want save :confused:

Hi , the file is saved probably but influxdb ignores it for some reason , what is the location of the file ? Default influx will look in program files\influxdb
and if no file found influxdb will use default parameters .
You can also specify the configuration file when you start influx using -config followed by the complete path to your config file ( there is a dash required ! -config )

Working! Thank you a lot guys! I dont why but inluxd started with deafult config file.