Missing data in system dashboard

For some time the system board displayed data but something happened and stopped displaying it. Now System board looks like this:

My questions:

  1. How to completly reinstall and setup InfluxDb 2.0 from the begining (I can’t do this, always InfluxDb starts from existing configuration after removing and instaling again InfluxDb)
  2. I added ads-b template (I have installed and working FlightAware with dump1090 and dump1090exporter, everything works flawlessly, I have aircraft positions from my ADS-B radar), but as for the System board in the ADS-B Flight Tracker board there is no data despite the fact that with dump1090 export generates them.

What is wrong in my InfluxDb 2.0 installation?

Hello @marekpow,
Have you tried changing the date selector to be from the past 7 days?
Here are the file system layout defaults:
https://docs.influxdata.com/influxdb/v2.0/reference/internals/file-system-layout/#file-system-layout

Yes, but there is no new, actual data, only for one day, few days back:

My InfluxDB 2.0 is installed on RPi4 with 8GB RAM and Ubuntu 20.04 LTS (for detailed information about my installation)

Hello @marekpow,
That sounds like telegraf isn’t reporting any more not like there’s a problem with InfluxDB. Have you tried restarting telegraf with the config from that template?

May be this screen shot wiil be helpfull:

Can’t start telegraf with ads-b configuration

Still 401 error.

Hello @marekpow,
It looks like you need to create a new token, and export it. I recommend going back into the UI under telegraf configurations and clicking setup instructions, It will walk you through doing just that.

Now it works :grinning:

But I still have the same problem with ADS-B Flight Tracker template

@Anaisdg

How to persist INFLUX_TOKEN and others?

export command is active only in current session, but when I run reboot then this change is lost.

sudo nano /etc/environment

Hello @marekpow,
You can create a token and edit the config and replace it with the token you’ve created. Then you can set the environment variable permanently in your bash_profile.