I *think* I successfully upgraded from v1.8.5 to v2.6.1 but I am not sure, help?

Please may someone help?

I followed this guide to upgrade from v1 to v2 (in my case v1.8.5 to latest v2.6.1)

I wanted to go the “automatic” upgrade route, and the guide takes you to a separate download page. Instead of opting to download binaries from that second page I chose this option:


Then I followed the instructions given at each stage, so I did this:

wget -q https://repos.influxdata.com/influxdata-archive_compat.key

echo '393e8779c89ac8d958f81f942f9ad7fb82a25e133faddaf92e15b16e6ac9ce4c influxdata-archive_compat.key' | sha256sum -c && cat influxdata-archive_compat.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg > /dev/null

echo 'deb [signed-by=/etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg] https://repos.influxdata.com/debian stable main' | sudo tee /etc/apt/sources.list.d/influxdata.list
deb [signed-by=/etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg] https://repos.influxdata.com/debian stable main

sudo apt-get update && sudo apt-get install influxdb2

sudo /usr/share/influxdb/influxdb2-upgrade.sh

After the last command I was prompted to enter my username, organisation, retention period, and bucket name. I just entered some random stuff, not relating to the current installation, I wasn’t sure if that was correct.

Now when I run influx version I get this: Influx CLI 2.6.1 (git: 61c5b4d) build_date: 2022-12-29T15:41:09Z - so that seems great.

There were no errors during this process.

I went to check up on Grafana, which shows live sensor data that I sent previously to InfluxDB (from Node-RED), and that data was never interrupted, it’s still there. So either the upgrade went really well, or really badly…

I went to check on the new web interface and pulled up http://server-ip:8086 and a page was returned with plaintext saying “Not found 404”.

Then I read this: The InfluxDB UI is packaged with InfluxDB and runs as part of the InfluxDB server. To access the UI, start the influxd service and visit localhost:8086 in your web browser.

so I tried to start the influxd service by typing influxd and got this: Error: listen tcp :8086: bind: address already in use - perhaps it was already running?


  1. Given influxdb version refers to “Influx CLI” being at the latest version, how can I know that InfluxDB has been upgraded properly?

  2. Is there a possibility that Node-RED is still posting to the old InfluxDB service which is still running?

  3. How can I troubleshoot the issue with “404 not found” error when trying to view the web interface?


Hello @hazymat,

  1. The influxdb command outputs the latest version of InfluxDB not the CLI I believe from reading the docs:

The influxd version command outputs the current version of InfluxDB.
influxd version | InfluxDB OSS 2.6 Documentation

just to clarify: influxd versus influx

  1. Yes there is a possibility. Please check 1. first. I’m not sure why you’re getting the 404

Thank you for making that clear

I had to restart the service (systemctl restart influxdb) and then everything started working - web interface worked, and my Node-RED instance started producing errors writing to the old InfluxDB.

Now I just have to work out a way to import the last 10 days of missed data from InfluxDB v1, as the migration process imported everything at the time, but I ran it 10 days ago and since then new data was written to the old instance!