Deleting series and measurements

I am trying to remove some measurements that I no longer need. When I execute DROP <measurement> it runs for a few minutes and completes without error, but the measurement is still there. I have also tried deleting series and dropping series with the same result. The only thing I have noticed since I ran these commands is that I now have runaway disk usage on my influx instance. Whereas I usually see a few GB difference in free space from day-today, ever since I ran these commands I am seeing 2GB/minute.

I have a feeling it is preparing to delete data in the background, but can’t find any documentation around what might be happening, or how I might be able to monitor what’s happening. I also noticed that I see a ton of Cache Snapshot operations in the log but I do not see it compacting anything. I am not sure if this is related.

I am currently on InfluxDB 1.8.1

Thanks for any help you can provide!

The space eventually recovered. It seems this might have been from the tombstone process. Though, once all was complete and things were compacting again, all the data i was trying to delete was still there. :thinking:

Hello @Mark_Wilkinson,
So the drop wasn’t successful?
That feels like a bug.

Correct. I’ve even attempted to just delete small ranges of data with no luck.

Can you share how you’ve tried to delete small ranges?
Would you be willing to file an issue please?

Either way I’ll forward this question to the InfluxDB team. Thank you.