Custom API not working anymore

Last week I found that the two custom api’s I use to store data, did not work anymore. I had to use ‘all access’ api’s to make it work again.

Can anybody explain to me why this is or what I am not understanding here?

I am a novice Influxb2 user. I have setup Influx on my home server to store data from two sources: solarpanel data, Proxmox data. Grafana is used to show it all. Influxdb is installed in a debian lxc. This has worked without trouble for about 7 months.

Last week I found out that the loggin of solarpanel and proxmox data did not work anymore but Grafana could still show data. I think I have upgraded proxmox somewhere around the time the logging stopped, but I am not sure. I have tried several things, including installing a influxdb in a second lxc.

can anybody tell me how to go back to use custom api’s (to make stupid mistakes less likely) or let me understand if I am doing something stupid?

Any help is greatly appreciated.

Hello @myinflux,
I’m not sure but I know users have encountered this before. What version of InfluxDB are you using? I don’t know if you made a “stupid” mistake, but I remember encountering issues where my API tokens stopped working in early versions of InfluxDB v2. So it very well might not be you.

Hello @Anaisdg,
Thank you for your reply. I indeed use influxdb2 on a home server. Do you know where I can find more information on this or find any known solution? I would like the API’s to function again.

Without knowing to much about the couse (obviously) I would like to add that it is not becoming of InfluxDB (or any database for that matter) if it’s API’s randomly stop working.