Problem getting InfluxQL to work on Influxdb 2.0.3

My first post, so let me start off by thanking you all for this great SW that has served as my persistance storage service in my openHab smarthome.

After updating to influxdb 2.0.3 openHAB3 allready had a v2 interface addon ready, and my (inplace) upgrade from 1.8 something to 2.0.3 went (fairly) smooth.

My Grafana panels on the other hand, were all broken, and I abandoned using it since.
Lately I missed it and decided to give the latest Grafana 8.3.3 a spin.
I had it working with Flux, but it felt alien to me and I really want to use the old InfluxQL instead.

I have followed to descriptions creating v1 database to bucket mapping, and a v1 user Auth.
(Tried both using this v1 user Auth and/or the Header Auth method; same result)

I have no problem connecting from Grafana, but queries return just an empty string.
I suspect I might have done something wrong along the way, and any help would be greatly appreciated.

Here we go: bucket:

omr@shs2:~$omr@shs2:~$ influx v1 dbrp list
ID                      Database        Bucket ID               Retention Policy        Default Organization ID
08c3b4d754a05000        openhab-db      69d6af7550af3294        Forever                 true    427da286ec49d684
08c3b5c681605000        openhab_db      69d6af7550af3294        Forever                 false   427da286ec49d684
08c3bb7cc5b43000        openhab         69d6af7550af3294        Forever                 true    427da286ec49d684
08c4d66bcdb43000        openhab_db      69d6af7550af3294        infinite                true    427da286ec49d684
omr@shs2:~$ influx v1 auth list
ID                      Description     Name / Token    User Name       User ID                 Permissions
08c4002beef43000                        openhab         openhab         06f1f3ef50380000        [write:orgs/427da286ec49d684/buckets/69d6af7550af3294]
omr@shs2:~$ curl --get http://localhost:8086/query?db=openhab_db --header "Authorization: Token c5heYDTRfynpj3UkQleV4s9N3b6LDRVdcTKMRoJyH1J0oLom3qZQivjOnwPsIcjjMqX7XX9td3x-rE674s-CBw=="   --data-urlencode "q=SELECT used_percent FROM openhab_db.Forever.BathTemperature WHERE host=host1"

As you can see I have tried retention with both Forever & infinite. Same result.

My openHab3 have no problem querying the same measurement: (probably using flux?)
(wanted to show you an image, but forum does not allow me as I have used up my 1 image. :slight_smile:
PS. Grafana forum allows 2…