Grafana data read from sensu

after upgradation to version2 , we are able to access database from cli and old data is migrated.
we are not able to write and read in grafana for the new data and not able to visualise it
we have created a new user for grafara as well with new auth token and given all the requred permission
could you please suggest the solution to this

HI @Sindu_Gokulapati,
Welcome to the community! Here is a great guide to get your solution up and running once again. Please note that 2.X uses the Flux language by default and token permissions. Once you get over these hurdles you will be back on track. You can still use InfluxQL aswell and the guide will help you out there:

we have followed the doc and are using InfluxQL (to retain old data) to configure grafana
the migrated old data is being seen in the UI but no new data is being pushed by sensu to influxdb
manually writing the data from sensu server also isnt working
please suggest the steps to take

I would suggest that the first step to take is to show us how you are trying to
insert data manually and what the result is - especially any error messages
you see, or which appear in log files.


Hi Antony
curl -X POST ‘http://INFLUX_IP:8086/api/v2/write?org=ORGNAME&bucket=test&precision=ns’ --header ‘Authorization: Token TOKEN’ --data-binary ‘weather,location=LOC temperature=82 1465839830100400200’
using the above curl to write data to a test bucket which gives the err: {“code”:“unprocessable entity”,“message”:“failure writing points to database: partial write: points beyond retention policy dropped=1”}
the retention period of the bucket is 500h

Makes sense to me, then, because the timestamp 1465839830100400200 is 13th
June 2016.


thanks Antony tried it without timestamp
worked manually
but it isnt happening directly, have added the token in grafana UI
is there any place else to provide auth ?

Sorry, sounds more like a Grafana question / problem now.


as we are able to see old data in grfana, doesnt seem to be a issue on its side
the new data isnt being pushed to influx via sensu
could you guide me on setting up the handler for the updates influx version

Okay, sorry, I should have said that it sounds like a sensu problem. I’ve
never even heard of that, let alone have any idea how to configure it to talk
to Influx. Maybe someone else here knows about it.


1 Like