Configuration of InfluxDB not working - as a service on Raspberry Pi

I am struggling to setup the configuration file of InfluxDBv2.

InfluxDB 2.0.8 (git: e91d41810f) build_date: 2021-08-13T18:22:30Z
Debian GNU/Linux 10 (buster) on Raspberry Pi

InfluxDB is running as a service.
I manually set the following environment variables:


I’ve setup the config file using CLI:

 influx config create --host-url "" --org michashaus --config-name influxConfig --active -t AUTHENTIFICATION_TOKEN_ILL_NOT_POST

The config was created in ~/.influxdbv2/configs.
Now I was trying to make use of the configuration file. I want to change the port, so I can type in the browser to access the graphical UI.
Therefore I’ve changed the url=… and added a bind-address property.

  url = ""
  org = "michashaus"
  active = true
  http-bind-address = ":1234"

I stopped InfluxDB and started the service again.
Unfornutaly I am not able to access the UI using Port 1234.

Besides the above I’ve tried to only add the http-bing-address property, changing the above mentioned environment variable to a specific cofig.yoml file and pasting my configuration in that file.

So far I had no luck.

What am I doing wrong?

Best regards,

@DezzardHD when you install influxdb2 as a service, it looks for config at /etc/influxdb/config.toml. Updating the http-bind-address property in that file and restarting the service should give you the result you want.

Setting the property in ~/.influxdbv2/configs has no effect because that file is only used by the CLI.

1 Like

I managed to get it working. :slight_smile:

I’m wondering why I didn’t find a clear distinction between the two configuration files (for CLI and for the database related stuff) in the documentation.
Might be worth noticing somewhere at the top of the documentation for configuration.

Thanks again!

Best regards