Chronograf on windows

I downloaded chronograf.exe. i am unable to find how to start chronograf on windows. Can you please help with the instructions how to start chronograf on windows?

Open command prompt. go to the chronograf directory. run the command chronograf.exe

Thanks for your response

I tried that…it is not working.

I downloaded the same version, and while executing the command, I get a firewall prompt, on which I said Allow Access. I am not sure what selection you made there.

Hmm… That looks like an Aero Glass theme. You wouldn’t happen to be on Windows 7 running in, say, 32-bit?

i am running on 64 bit…are you saying we will not get this issue in 32 bit?

I just tested it out on 32-bit Windows 7. You would have gotten an error.

I’m still looking for a 64-bit Windows 7 image in order to repro. I don’t have one in my possession currently.

I don’t suppose you could use more recent version of Windows?

I just tested Chronograf on a Win 7 64-bit VM. I am not able to reproduce your issue, given the happy path of downloading the latest chronograf exe for Windows (64-bit), confirming the Windows network pop-up, and going to localhost:8888 in Chrome or any browser that isn’t stock IE 8.

here is the version i downloaded…did you try the same?


Thanks a lot for your help.

Yes, in all cases, that is the release I tried. I tried them on a Windows 10 VM, and Windows 7 32- and 64-bit VMs. My apologies for not being able to be more helpful… I even tried resetting the firewall prompt, as Pankaj noted might be the case earlier, and was not able to repro your issue, with the early, errorless exit.

I have to admit, I’m running out of ideas.

Just summarize for others who might be able to assist with this issue, and correct me if I’m wrong on any of these points:

  • You’re using the 64-bit Chronograf 1.3.7 Windows release.
  • You’re trying to run it on Windows 7 64-bit.
  • The program exits immediately with no further console information.

Does that about sum it up? Do you have any further information you can provide, or any bright, last-minute ideas?

Another thing I tried was running a server that uses the port 8888, and then starting Chronograf. Apparently, the binary has no issues competing for that port, as it would on a POSIX system. That said, you don’t think there’s something on your machine already running on 8888, right? Further, I don’t suppose you could restart your machine, just to rule out any other gremlins?

Another way to rule out a port issue is if you try chronograf.exe /port 8000, or some other random port.

I would try running the cmd window as administrator, if you right click on the item in the start menu you should see the option.

Thanks everyone for your help.

I tried running “chronograf.exe /port 8000” and also as an administrator, still same error.

I would like add one more point after running “chronograf.exe” from command prompt for some reasons this .exe file is getting disappeared.

Please let me know if you think of anything what can cause this issue.

Could a virus scanner be blocking it?

1 Like

that definitely sounds like a program is quietly trying to quarantine chronograf