Wrong sha256sum for Telegraf using influxdata-archive_compat.key

Hey there,

I already setup a TIG solution on a server.
I was trying to install Telegraf on my remote Proxmox to collect internal data and send it to my influxDB V1 base. I followed my documentation, then the official one after failing:

Then running those commands:

curl -s https://repos.influxdata.com/influxdata-archive_compat.key > influxdata-archive_compat.key
sha256sum influxdata-archive_compat.key

Returns me the checksum e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 influxdata-archive_compat.key and on the doc it should be 393e8779c89ac8d958f81f942f9ad7fb82a25e133faddaf92e15b16e6ac9ce4c.
This is a problem since I can’t continue the installation:

echo '393e8779c89ac8d958f81f942f9ad7fb82a25e133faddaf92e15b16e6ac9ce4c influxdata-archive_compat.key' | sha256sum -c && cat influxdata-archive_compat.key | gpg --dearmor | tee /etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg > /dev/null
influxdata-archive_compat.key: Failed
sha256sum: Warning: 1 checksum does not match

I’ve also tried with wget.

Also tried to download the influx-archive.key file, and got the same error with the same checksum.

Hope I’m not going anything weird…

Thank in advance!

Okay, I had a problem on my /etc/resolv.conf file, which was a little bit complicated to download a file from Internet.
I’ve been able to figure this out by using scp to send the file on my proxmox, then trying to install sudo for the next, which didn’t work as well…