GPG key for repository broken since Jan 26


It seems the GPG key at was updated on Jan 26th. Since then I have been unable to install telegraf. I have tried removing the public key and letting it redownload, and I’ve tried installing different versions of the package. Is this something you’re working on?


Downloading packages:
warning: /var/cache/yum/x86_64/7/influxdb/packages/telegraf-1.9.1-1.x86_64.rpm: Header V4 RSA/SHA512 Signature, key ID 7df8b07e: NOKEY
Retrieving key from xx(can only have 2 links in my post)

The GPG keys listed for the “InfluxDB Repository - RHEL 7” repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

Failing package is: telegraf-1.9.1-1.x86_64
GPG Keys are configured as:


The old GPG key, influxdb.key, itself was not updated. Instead a new key with a new name was generated. The old key will be revoked in the near future. For more details around this change take a look at this blog post.

To get you going again on your RPM system you can update the gpgkey value to the new key:

The instructions on the project README and downloads pages were also updated.

Hope that helps!


1 Like

Appreciate the response @jpowers - I’ve marked the thread as resolved.