Unable to delete data points from measurement

Hi All,

I have below command from chronograph, it returns “Request failed with status code 400”
DELETE FROM “”.“autogen”."" WHERE time > ‘2019-11-30 00:00:00’ and time < ‘2019-11-30 02:10:00’.

Anyone tried deleting data points for particular time period ?
If chronograph is not the right way to perform delete activity, Any other approaches to delete data points ?

Cheers,
Pandit

Hi All,

Update from my side, I am able to login to InfluxDB and performed few select queries and got results

SELECT * FROM “” WHERE time > ‘2019-11-30 00:00:00’ and time < ‘2019-11-30 02:10:00’

But when perform delete operation, it failed and gave below error message
DELETE FROM “” WHERE time > ‘2019-11-30 00:00:00’ and time < ‘2019-11-30 02:10:00’
Error:
ERR: cannot delete data. DB contains shards using both inmem and tsi1 indexes. Please convert all shards to use the same index type to delete data.

Now I am checking how to convert shards into same index type.
If anyone already had this kind of situation please provide your insights.

Cheers,
Pandit.

You may have simply changed your configuration setting at some point from inmem to tsi1 without running through the process of actually creating the TSI index itself. That would mean all new shards are using TSI1 and the older ones are not.

Here is the process for rebuilding the TSI index: https://docs.influxdata.com/influxdb/v1.8/administration/rebuild-tsi-index/

Hi Tim,

True, I tried deleting very only data. In between we upgraded influxdb. Now all the shards are in TSI index . I will try deleting some latest data.
Thank you for the link, i have gone through it.

Cheers,
Pandit.

I had same problem as OP. I followed the steps in the link you provided but after running influx_inspect, those directories (_series and index) came back.
Is this expected?