Unable to access admin ui again after initial install - influxdb2

Hi there
I installed influxdb2 OSS on my ubuntu 20.04 server. as written in documenation I entered the ui under
http://ipaddress:8086 in my browser and was redirected to the onboarding page to setup the first user password, organization and so on. This went like a charme - no problems.

When logged out after this initial onboarding activity there is no way to get back again in that admin ui.
The login page appears asking for username and password. Providing both properly leads always to a red box in the upper right corner telling “could not sign in”.

on server the log says

Apr 11 15:10:46 lvl=info msg=Unauthorized log_id=0TSG6pk0000 error=“token required”
Apr 11 15:10:46 lvl=error msg=“api error encountered” log_id=0TSG6pk0000 handler=session error=“unauthorized access”

any help is highly appreciated
Regards

Hello @urmel1960,

That’s strange. Do you have a token?
Are you able to execute a cURL successfully?
Have you tried setting it up again through the CLI?
https://docs.influxdata.com/influxdb/v2.0/get-started/?t=CLI+Setup

Hello @Anaisdg

Unbelievable :slight_smile: That way around worked.

When I do the first setup in the UI then I am not able to log in again after first logout - as described
When I do first setup via CLI then I can logout and login again as expected. Strange - maybe worth to amend documentation ?

Now I got a config file in roots homedir /root/.influxdbv2/config containing entries for url, token, org and active flag.
As the install is as systemd service on ubuntu server 20.04 I would have expected that kind of configuration in /etc/influxdb ??

I could not find anything about this in the documentation ?

Any advise where to look ?

Thanks

Hello @urmel1960,
Honestly that behavior is strange. You should be able to log in again after first logout through the UI. Consider filing an issue?

Yes I can do this - any idea where to go for filing an issue ?I visited support.influxdb.com but my credentials for the community I am not able to log in …

Hi, I have a similar issue too with influxdb2. The User account I created during the initial setup seem to have worked for a day. When I try to login again the following day, I keep seeing the ‘could not sign’ message even with the right credentials.

I wiped out influxdb2 and set it up from scratch again, but ended up having the same issue after a day. I am on windows 10 /Influxdb V2.0.9.

As suggested in one of the responses above, when I try to create a new user via CLI, I get unauthorized error access.

Any solution/workaround is appreciated. Thanks.