Telegraf SNMP Plugin Error Cisco ASA

I’m new to using Telegraf and Influx. I’m having an issue collecting anything from 2 separate ASA’s via SNMP. I keep getting the following error when I do a --test --config:

2018-01-12T23:01:54Z E! Error in plugin [inputs.snmp]: agent 10.111.1.1: performing get on field hostname: Request timeout (after 3 retries)

Here’s my config file:

[[inputs.snmp]]
agents = [ “10.111.1.1” ]
version = 3
sec_name = "***"
auth_protocol = "SHA"
auth_password = "***"
sec_level = "authPriv"
priv_protocol = "AES"
priv_password = "***"
interval = "20s"
timeout = "10s"
retries = 3

[[inputs.snmp.field]]
name = "hostname"
oid = "SNMPv2-MIB::sysName.0"
is_tag = true

[[inputs.snmp.field]]
name = "uptime"
oid = “DISMAN-EVENT-MIB::sysUpTimeInstance”

I’ve tried both v2 and v3. I’ve tried collecting the hostname as a tag and not a tag. I’ve tried so many things I’m forgetting what I’ve done. I ran a packet capture and traffic is flowing back from the correct IP and on the correct port. The odd thing is that Telegraf continues to send GET requests even though (what seems like) the correct response is coming back from the ASA. snmpwalk and snmpget both work and return expected values.

Am I missing something? All software is up to date.

Any help would be much appreciated!!!

We have a similar issue open on the issue tracker which might be what you are experiencing: https://github.com/influxdata/telegraf/issues/3655

Yes, this is the same issue I’m having. Thanks for pointing me in that direction.