Telegraf for OPC-UA avoids writing values of double data type

I have been running Telegraf on windows (1,20.0) and it connects to a OPC-UA server simulator. Simulator will generate two int values and one double value for three fields. I have tested this with UaExpert which is a OPC client and saw the values getting updated, collected from the server as in the below image.

But when tried with Telegraf, with chronograf dashboard I don’t see double values generated for the Tag11 is written into InfluxDb.
I even checked with a excel sheet generated with logged values, where i found no luck finding Tag11 values. Below image represents the data collected from the Telegraf shown in a dashboard.


Telegraf config file has below node configuration. even changed the idenifier type to i(numeric) but still doesn’t work.

Have a look at the telegraf and/or InflxDB log, my guess is that the field has been created as data type int, and now you are trying to write floats to it… which is not possible.

you can’t change the data type at DB level (or better shard level, as data types are per shard, which means you can have mixed data types).

The solution for this kind of issue is to convert the value to the desired data type before writing to the database, see converter processor.

1 Like

May be that’s the case. Sure will check and let you know ASAP.
Thank you.