Start of influxdb ignoring config.toml or not correctly

Hi i have a private local influxdb2 instance which has been running since a couple of month without any problem. It is a native installation, no docker, from the package manager. It’s a Debian 11 OS.

In the first days of mai, (6-7 days ago from today) the instance stopped working. I think it was the time when I updated the influxdb 2 to version 2.7.1.

I tried to find out yesterday about 5 hours what the root cause is, and it looks to me that influxd not correctly reading from the config file or interpreting them correctly.

I use the default systemd config which relies on /etc/influxdb/config.*

It used to work with split config in the config.toml and config.yml but this seems not to work anymore. It looks like if there is a config.toml the config.yml is ignored completey which used to be different when I setup the instance.

But still when I moved all config to the config.toml, the instance is starting, my wildcard certificates are used correctly but then I see the animated circle icon and nothing happens anymore.

What is disturbing me: starting influxd mit the config passed by flags work like a charm.

So as a workround I ended up creating my own startup script which I placed in the scripts folder and edited the systemd config to use this as a startup. Now my instance is running again without any problems:

The config I set is:

/usr/bin/influxd --tls-cert=/etc/influxdb/certs/wildcard.XXX.bundle.crt --tls-key=/etc/influxdb/certs/wildcard.XXX.key --bolt-path=/var/lib/influxdb/influxd.bolt --engine-path=/var/lib/influxdb/engine --http-bind-address=:8086 --tls-min-version=1.2 --flux-log-enabled=true &

Any idea why this is not working with config.toml and the normal startup script?

By the way a hint to the developers, influxd print-config is depreciated, the startup script maybe need to be revised anyway.