Replication Issues

We are having some replication issues, some LP are not been replicated (influxdb version 2.7). But we do not see any error in the influxdb log.

This an example:

Node 1





Node 2




We have the replication configuration with --no-drop-non-retryable-data. Is there a way to see the information in the queue to try to investigate what is happening?

We are using the “influx replication list” command to monitor the replication, but no error has been detected ( e.g: “replications”: [{“id”: “0b45fcb1083f4000”,“orgID”: “f1c1a59ddf65a579”, “name”: “my_replication_stream”, “remoteID”: “0b45fcaff4d37000”, “localBucketID”: “872d031ba055152b”, “remoteBucketID”: null, “RemoteBucketName”: “our_metrics”,“maxQueueSizeBytes”: 10737418240,“currentQueueSizeBytes”: 10205395,“remainingBytesToBeSynced”: 0, “latestResponseCode”: 204, “latestErrorMessage”: “”, “dropNonRetryableData”: false,“maxAgeSeconds”: 604800

Is there another way to monitor the queue?

Also in this ticket Add field for dropping "non-retryable" errors to replication streams · Issue #22880 · influxdata/influxdb · GitHub we have read: “t is possible that remote write errors will be encountered for which retrying does not provide any hope of success, such as a 400 error which means that the LP data could not be parsed” How it is possible a LP is parsed by the node 1 and not by the node 2.

I am also trying to replicate the data, but I am unable to as it’s giving me the error.

Error: failed to create replication stream "kpi": 400 Bad Request: failed to unmarshal json: id must have a length of 16 bytes

I am giving this command to replicate the data
influx replication create -n "kpi" -t 1y1PmfsghadfhsgfjdgsjfgmdOuMyW84P9a9Pt4hB7jcTkVKsE-NnhHjzOwJ_PkBqMWZIZLXjrTOn9-tvJUkQ== -o "org_name" --local-bucket-id "b0375a0456d3d3" --remote-bucket "b46jger923479" --remote-id http://server_ip:8086

I am tried giving the values with and without quotes, I tried passing the name using the proper flag but every time I get the same error.

could you please me with the same?

The remote_id must be the id of a remote generated with this command: influx remote create --name remote_test --remote-url url --remote-api-token xxx --remote-org-id xxx

I have found the error, I open a ticket for more details,
In a database with a replication configured, In a written with points below and in the retention period none of the point is replicated. · Issue #24263 · influxdata/influxdb · GitHub