Regaining access to existing database instance v1.7.7

I have a business application running several IoT devices that send their data to an influx instance through a telegraf agent. The individual that initially deployed this project is inaccessible, but left behind credentials to access the various services in the tech stack. However, the only username and password pair that does not work is the one associated with the admin user for our influxdb. Is there a way to recover a password or alter the user credentials through the linux shell without destroying the significant amount of logged data and rebuilding the database from zero? I have found several solutions, but the recovery command wasn’t added until v2.2 and I have been unable to locate an influxdb.bolt file that might contain hints as to what the correct credentials are.

An alternate solution might be updating the instance version from 1.7.7 to 2.2 or later, and then utilizing the recovery command. Is this something that is possible without having admin credentials and also preserving the existing data?

Hello @Travis,
Yes you should be able to upgrade and preserve the existing data. I’d try that.

Hey @Anaisdg
Thanks for the response, I managed to figure out how to upgrade, and 2 of my 3 servers worked flawlessly, automatically importing the v1 users and databases into new buckets. I’m very happy with how well that worked.

However, the 3rd database, for a reason that is unclear to me, did not automatically import the users and databases in the upgrade. I have made new login credentials for it, and can access the web ui and terminal just fine, but I’m a little unsure on why it didn’t upgrade quite as smoothly as the other two.

As far as I can tell the .conf file settings were identical across the three servers, and nothing should have been different between them. So now I’m wondering if there is a super fast and easy way to import old users, or if I am going to have to create new users and buckets to write to and read from. I can see the old database file still exists, so the data is fine, but I’m not sure how to access it.

I dont think that there is a way to import users. I apologize.