Performance issues after conerting indexes from inmem to tsi1

influxdb

#1

Hi every one,

In my project, I have to work on HDD (on which InfluxDB is absolutely not optimized for). Well I ran a docker container with influx1.7.0 inside. I noticed I have let configuration default, which make the indexes inmem.

So I ran the command: influx_inspect buildtsi -datadir /var/lib/influxdb/data -waldir /var/lib/influxdb/waldir to execute the conversion, then I restarted the container and executed this command: influx -execute "SHOW STATS"

As a result I am well on tsi1 for the indexes as it shows it:

name: shard
tags: database=TestDB, engine=tsm1, id=4, indexType=tsi1, path=/var/lib/influxdb/data/TestDB/autogen/4, retentionPolicy=autogen, walPath=/var/lib/influxdb/wal/TestDB/autogen/4
diskBytes fieldsCreate seriesCreate writeBytes writePointsDropped writePointsErr writePointsOk writeReq writeReqErr writeReqOk
--------- ------------ ------------ ---------- ------------------ -------------- ------------- -------- ----------- ----------
551777362 0            124000       0          0                  0              0             0        0           0

Nevertheless, after running a previous test (in this test, I compute mean values on an hourly timerange on the whole DB), I noticed that it was absolutely not faster, but the same result …

An other important point, because in the container the server is ran with infludx as daemon (influxd) and it is the main process (PID=1) so you agree with myself that if I reset the process it will shut down the given container? So I did not, and because I am curious, I tried with the service, but it says me it is already stopped o_O I assume that it does not see the daemonized process:

service influxdb stop   
influxdb process already stopped [ OK ]

I sincerely hope my lack of performances is due to the fact even if it converted the indexes from inmem to tsi1, the fact I did it with daemonized process could explain this behavior.

Kind regards