Migration from 0.12.2 to 1.7.3

#1

Hello all.

I need to migrate the data from influx-0.12.2 on centos6 to influx-1.7.3 on centos7.

I backupped the data in this way (my database name is data)

~ $ mkdir backup-test && cd backup-test
~ $ influxd backup -database data .

Now I have the backup-test directory with the data.SOMETHING file in.

After move the directory to the new server I tried:

~ $ influxd restore -db data -datadir /var/lib/influxdb/data -metadir /var/lib/influxdb/meta backup-test
Using metastore snapshot: backup-test/meta.00
2019/02/07 14:57:27 Restoring offline from backup backup-test/data.*

Now I’m able to see the file into /var/lib/influxdb/data/data/, however, from the influxdb shell, while I type ‘show databases’ I don’t see the database created.

So I repeated the entire procedure but before that I created the database with:

create database data with duration 60d

After create the database I don’t see its directory in /var/lib/influxdb/data, I see it only after the restore command.
The problem now is that when I type show measurements from the influx shell after using the data db, I don’t see anything, so I have the data but there are no relation with my db and the restored file.

What I am missing?
Thanks in advance

0 Likes

#2

Hi , sorry for the late reply , is your problem solved ?
What are the parameters in your configuration file for data , wal and meta dirs ?

0 Likes

#3

Hi, unfortunately the problem is not solved.

The configuration file was not touched after the installation, so it is the same provided.

0 Likes

#4

Looks as if something is wrong with your meta data …
Can you share the output of :

 influxd config | grep -i dir

ps :
After creating a database you will not see it in the data dir ,
because there are no shards created yet.
It is only after you insert data that you will see it , or after the restore as you experienced.

please also note that

A critical defect in the InfluxDB 1.7.3 release was discovered and our engineering team fixed the issue in the 1.7.4 release. Out of high concern for your data and projects, upgrade to the 1.7.4 release as soon as possible.

see this link …

1.7.3 problem

0 Likes

#5

As requested, this is the output:

Merging with configuration at: /etc/influxdb/influxdb.conf
dir = “/var/lib/influxdb/meta”
dir = “/var/lib/influxdb/data”
wal-dir = “/var/lib/influxdb/wal”

0 Likes

#6

Hi ,
I was able to simulate your problem ,
I did a restore while influxd was up and running ,
I could not see the database .
after a restart of influxd the database showed up and everything was restored …

did you restore while influxd was running ?

0 Likes