Login to new Influxdb 2 installation

I have a new install of influxdb 2 on a raspberry pi 5 using PiBuilder and IOTstack. Docker is up and running as is Portainer-CE and Node-Red. Other yet to access are Mosquitto and Grafana.
It’s been a long install, surprisingly with no errors reported.

I’m trying to access each of the installed applications in turn. docker ps -a shows all containers up and running.

The problem is with the influxdb login. I’m accessing each application by hostname so for influxdb this is raspberrypi.local:8087

There’s no cert for influxdb so it’s just plain http:// etc

The first thing presented is a login screen. I expected to be invited to add a user, but no.

At the login there’s no user/password that gets me in. I’ve tried Administrator/Administrator1, admin/admin, admin/password, root/root and so on…

I’d be grateful if someone can help me over this unexpected obstacle.
Thanks in advance,

Hmm that’s very odd.
When you startup for the first time you should be prompted to setup.
Can you share your dockerfile?

Hello and thank you for your reply.

I tried various CLI recovery methods suggested previously to others who’d lost or forgotten user credentials. None worked.

I solved the problem only by removing the container and rebuilding outside of IOTstack. Setup then proceeded as expected first by adding a user.

Interestingly, that brought a greater level of control to docker and, with it, visibility of volumes within Portainer.

Thx again,

Hi again,
Rooting around the install files I found this:
… in there we have:
container_name: influxdb2
image: “influxdb:latest”
restart: unless-stopped
- TZ=Etc/UTC
- DOCKER_INFLUXDB_INIT_ADMIN_TOKEN=my-super-secret-auth-token


- “8087:8086”
- ./volumes/influxdb2/data:/var/lib/influxdb2
- ./volumes/influxdb2/config:/etc/influxdb2
- ./volumes/influxdb2/backup:/var/lib/backup

- ./volumes/influxdb.migrate/data:/var/lib/influxdb:ro

test: [“CMD”, “influx”, “ping”]
interval: 30s
timeout: 10s
retries: 3
start_period: 30s

“me”/“mypassword” gets me into both Influxdb and Influxdb2 installed via IOTstack

I’m no longer using IOTstack to install Influx. Besides, the anticipated arrival of Influxdb 3 (or is that Influxdb Edge?) and the reversion to InfluxQL means I won’t need to learn Flux. It’s fresh install time.