Grafana Datasource: Inxluxdb v2 always Error 401

Hi all,

this is my system:

Raspberry Pi3 (latest OS)

$ cat /etc/*release
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
VERSION="11 (bullseye)"


$ grafana-server -v
Version 9.1.1 (commit: 9e60a1bff1, branch: HEAD)

InfluxDB v2

$ influx version
Influx CLI 2.4.0 (git: 5c7c34f) build_date: 2022-08-18T19:26:48Z


$ telegraf --version
Telegraf 1.23.4 (git: HEAD 5b48f5da)

Everything installed fine and running as a service.

I can not log in to my Influx DB v2 web interface.

  • I open
  • InfluxDB login screen appears.
  • I log in with admin and my password (only alphanumeric)
  • A red message appears on the right top corner “Could not sign in”

So how can I reset the admin pasword?

I searched with google to reset password, but the result only supply command which do not work or where I get a “401” Error, like:

influxd upgrade --username='admin' --password='admin' --org='MyOrg' --bucket='MyBucket' --force

also tried with token, same errors … all gave ERR: 401

Could anyone be so kind and help?
If you need further information about the system please feel free to ask.

I am really frustrated, because it seems, that all the google results are for influx v1 :frowning:


Hi @Miky,
You should be able to look at your original username and password if you inspect the bolt file of InfluxDB. This forum should help you out:

1 Like

Hi @Jay_Clifford ,
thanks for your advice.

I tried the parts from the mentioned thread:


$   sudo  influxd inspect 
See 'influxd inspect -h' for help

For me its not clear here, what to inspect, that would help me, when I try “-h


sudo vim /var/lib/influxdb/influxd.bolt

In this file I only see ^@^@^@^@^@^@^@^@^D stuff
but also the admin with the token.
But to log in on the InfluxDB login page I deed a passwort to log in and not a token.

I can extract:

  • userID
  • orgID
  • token

But I cant imagine how that can help me to login with username and password.

Surprisingly, I could change the admin apssword with the following command:
influx user password -n admin -t MyToken

That solved my problem - I can log in now!

Thanks a lot for pointing me in the right direction :smiley: :+1:

1 Like