Interrupt plugin not working

i tried using the interrupt plugin [[inputs.interrupt]] and set the cpu_as_tag parameter to true in telegraf.
but the plugin didn’t create any measurements as expected.

not only it fails to create a new measurement and populate data into that but after restarting telegraf other measurements also stop getting populated. once i remove this plugin from the configuration file nad restart telegraf again everything goes back to normal.

can anyone please help with this situation?

Hi @neo1702

there is an ‘s’ missing … it should be :


best regards

yeah… sorry that’s a typo… that doesn’t exist in the configuration file.

#Gathers metrics about IRQs
cpu_as_tag = true
##When set to true, cpu metrics are tagged with the cpu. Otherwise cpu is
##stored as a field

that’s how it is written in the configuration file.

Hi @neo1702 ,

can you test as follows ?

create a file configtest with the following lines …

files = ["/tmp/testing.out"]

cpu_as_tag = true

and then run in the same directory where the configtest file is : telegraf --config configtest --test

getting this error:

Error running agent: Error parsing fileName, line 76: field corresponding to cpu_as_tag is not defined in *interrupts.Interrupts

hi @neo1702 ,

i should have asked first : what is your telegraf version ?

telegraf -version

ps : your configtest file has at least 76 lines ?

Telegraf 1.9.2

actually i used the original config file only that’s why 76 lines.
everything else is commented.

I have tested it with your version and I get the same error ,
with version 1.11 it works …


thank you for the effort.
any suggestions??

if you uprade telegraf to the latest version it will work . ( I have tested it with 1.11.2 :slight_smile: )

thank you for the help