Influxdbv2 unauthorized to read buckets through GUI

Hi all,

I am continuing the discussion from InfluxDB OSS 2.0.1 giving unauthorized messages after install:

After following Influxdbv2 install instructions with a fresh install on Linux 64-bit VM, setting up the DB, and attempting to view a bucket, I receive unauthorized error: “token required” in CLI window running influxd. Very similar to this issue also: InfluxDB2 does not load buckets (and data) when changing browser or ip · Issue #16683 · influxdata/influxdb · GitHub.

I am accessing influx instance through a web browser that is running on the same VM as influx, not sure if this could be the root cause of the issue.

I am not sure of any environmental specifics that could be causing this, so any suggestions will be greatly appreciated.

Unfortunately, I don’t have the available resources to stand up another VM as a work-around.

Note that I’m able to write data to influx using the tokens provided, but as far as I’m aware, it is not possible to pass tokens through a web browser to read buckets.

Running Oracle Linux Server 7.6 on x86_64 architecture, with VMWare as hypervisor, and have tried multiple versions of Influx2 (2.0.0 Beta, and 2.0.4)

Thanks for any help in advance

Not sure I follow what your use case is using your browser. But it’s definitely possible to specify your toke using curl or wget using the headers option

https://docs.influxdata.com/influxdb/v2.0/reference/api/#authentication

If you login normally, and navigate to the tokens screen, are all the tokens you expected to be there actauallly there? Do they have the write permissions (or read and write) ?

I am simply trying to view a database using influx 2’s GUI that is accessible through a web browser.

With regards to the tokens visible, I am able to see a single token for the user created upon influx2 setup.

This token maintains administrative level privileges across the board.

However, when I try to ‘explore’ the data (logged in as the admin user), influx2 logs an unauthorized error “/“error”: token required”/".

I have reinstalled multiple times by removing /home/$user/.influxdbv2/, & /usr/bin/local/{influx, influxd} before unzipping/re-locating and then running the daemon but I still receive the same error.

I have managed to resolve this issue by updating Linux packages (sudo yum update)…followed by a reboot.

Still not sure what the initial cause was, probably an outdated browser or other package (I was using a fairly old distro).

Thanks for your help!