InfluxDB has stopped writing data

I am using InfluxDb since last two years. Everything was fine till 3 days back when my Ubuntu started misbehaving. I uninstalled some packages and reinstalled Conda environment.

Since then I am not able to write data to my influxdb databases. I have tried everything. Uninstalled and re-installed InfluxDB. Same for Anaconda. Have checked write permissions. Created new database. But nothing works. I can read data, but cant write. Also at the time of writing, I get ‘True’ message from Influxdb. But new data is not there.

I will be very happy if anyone can help me in this regards. The data that I have saved is very costly and I need to upgrade that on daily basis. I will be thankful for any help.

Harish

Hello @aharish,
What version of Influx are you using? How are you trying to write data? Do all of these methods fail?:

  • curl
  • Influx UI
  • Telegraf
    Can you please share details about all of the methods you’ve tried? Configs, commands, and logs?

Hello Anaisdg,

Thanks for your reply.

My version is 1.7.9.

I write through Python only. Specifically I use df_client.write_points() method. I have never used any other method.

The same code was working beautifully for two years before it stopped two days back. I can still read all the data, just cant add new data. Something has gone wrong at the database level.

What other information can I provide? Is it possible that I give you a remote connection so you can check it yourself? I have just working knowledge of Influxdb and no knowledge about database management or maintenance.

Harish

@aharish,
Can you please try a curl and supply the logs?
and then provide the python code as well as the logs?

@Anaisdg

Thanks for your reply. I tried writing through curl. No success.

I got HTTP/1.1 204 msg. But data wasn’t written into the db.

I am not able to attach any file as I am new user. I have put all files in https://drive.google.com/drive/folders/1j4N9utJCH0LN9rhCGoAiJEmyIsWQtxnv?usp=sharing

There are three files: log file, my python code and terminal snapshot.

Waiting for your reply,

Thanks again for your help.

@aharish,
It looks like your curl was successful. Can you please show me what you’re using to query that point and the output?
Thanks :slight_smile:

Hi Anaisdg,

My mistake. Curl write was successful. I queried the data and test data was written into DB. I am really sorry that I missed it the first time. I am not used to shell commands and I use Python mostly. When I queried from Python program, I found the test data.

But I tried to write my work data again but it failed. df_client.write_points() isn’t working. It used to work perfectly.

Please help as my complete work is based on storing and analysing this data.

Harish

@aharish,
Well that’s good news! My guess is that there might just some small mistake in your python script. Can you please copy and paste your script for me to try on my machine? We’ll get this figured out :slight_smile: