InfluxDb 2.5: error 401 access denied when executing "influx server-config"

I recently upgraded a 1.8.10 installation to InfluxDB V2.5.1 on a Debian 9 machine. bolt-path, sqlite-path and engine-path have been re-directed to a custom path by modifying respective configuration files.

Initially, the configuration pointed to the default directories:

  • bolt, sqlite and engine pointed to /root/.influxdbv2

When starting InfluxDB in this initial configuration via sudo systemctl start influxd, I was able to display the influx server-config without any problems.

However, after re-directing the path to the custom one, it is not possible to display the server-config; I get a “401 unauthorized” error. I CAN log in via the web-UI and admin user.

Things I tried (all lead to error 401):

  • influx server-config
  • sudo influx server-config
  • created new operator token in web-UI (All purpose token). With this token
  • influx server-config -t
  • sudo influx server-config -t
  • Changed ownership of custom directory from root to influxdb and back

Note: not only “influx server-config” does not work, but as it seems any critical “influx”-command throws 401.

Now I am lost. Any help appreciated.

OK, I found the error: as it seems, I made a copy/paste error when copying the admin token. After copying this correctly, the “influx server-config -t ” worked.