InfluxDB 1.8, "Verify flux-enabled=true in InfluxDB.config". I have no!

I have (Node-Red, Home Assistant), InfluxDB 1.8 and Grafana 9.3.6 in Docker on a Synology NAS.

I have lots of data and graphs, but to be able to group by Jan, Feb etc, I am trying to get Grafana to use flux.

The configuration of this in data source Grafana gives the error:

“403: Flux query disabled. Verify flue-enableed = true in the [http] section of the InfluxDB.config”

I cannit find an InfluxDB.config!

SSH’ing into the NAS, I have looked in the

“/etc/influxdb/influxdb.conf”…no influxdb folder

From the Docker Volume settings:

“/docker/influxdb”…folder empty
“/var/lib/influxdb”…no influxdb folder

From what I read there should be a part populated one somewhere ready to be modified, so I am reluctant to create one with the “flue-enableed = true”, and I wouldn’t know where to put it!

Can someone point me in the right direction please…thanks

1 Like

To the best of my knowledge, flux is not part of InfluxDB 1.8

Flux was introduced with InfluxDB 2 (which also has a backward-compatible
InfluxQL facility), so you’ll need to upgrade Influx to be able to use the new
query language.


Pooh, This is what I am going by…I aam assuming that it still holds true.

Ah, apologies, I wasn’t aware of that. However, I haven’t tried to use Flux
so far, in any version of InfluxDB, so I hope there is someone else here who
can help with your question.

In the meantime, it might be helpful if you would tell us:

a) which operating system and version are you running Influx under?

b) how did you install Influx on it?

c) if you installed a packaged version, where did you get the package from /
if you installed from source, where did you get the source from?


OK, Antony, not enough info…

The Synology Nas is running its latest DSM 7.1.1, and Docker within that.

SSH into NAS and installed InfluxDB (I think from the Docker Hub) with:

“sudo docker run -d --name=“influxdb” --net=host --restart always -p 8086:8086 -v /volume1/docker/influxdb/:/var/lib/influxdb influxdb:1.8.4”

The above came from one of (I think) better videos…I linked HA, Grafana, Node-Red, MQTT and it all seems to work so far.

So, all help welcome…

InfluxDB does not require an explicit config file to run, if none is provided it has an “internal” default config, you can then override it with Env variables or config file.
the priority is EnvVariables → conf file → internal config.

You can look for more here.

InfluxDB is configured using the configuration file (influxdb.conf ) and environment variables. If you do not uncomment a configuration option, the system uses its default setting. The configuration settings in this document are set to their default settings.

You can get the default (internal) config by running influxd --config, put that into a file and change the influxDB “execution/startup” to run with influxd -config /etc/influxdb/influxdb.conf

1 Like

That’s great…I’ve got InfluxDB-Flux in Grafana…many thanks