Flux is Enabled in config but not enabled in influxd

influx db v1.8,

I am new to influx. I have been working on Influxd to extract my data in a neat format with tag values as rows and timestamps as columns for all of my tag values. I know i need to use pivot function of flux for this. But the problem is that I am not able to enable flux on my influxdb.
If I use “-config” command to point to my edited config file it works but then my restored database does not show up in buckets/databases.

I have tried everything. But still not able to achieve it. Apparently there is another config file that influxdb reverts to by default, becuase it keeps working even if I delete the config file in the influx folder.

Attached is the screenshot of my influxdb config file.,

Hello @Sajeel_Ahmed,
What errors are you getting?
Can you upgrade to 2.x?
What environment are you running it in?
How are you trying to use Flux? Through the UI?

These resources might help:

Hi @Anaisdg. Thanks for your reply.

  1. I am getting the error “flux query not enabled”.
  2. Its the same for Influx cli and Grafana.
    Due to this reason I am not able to add a datasource based on flux in Grafana.

I have already gone through the link you mentioned. The thing is I am able to point to my edited config file and it enables flux but It no longer shows my restored database then.
Is there any other config file my influxdb is referring to by default? By other I mean other than the one in my influxdb folder.
I have also tried echoing the config path environment variable but it just comes back with the name of the variable that I typed.
echo $influxdb_config_path will give

unfortunately I cannot update my influx to 2.x. As doing so will alter the existing data collection or might stop it and I am not skilled enough to set up a new one.