Influxdb 1.8 rpm install and configuration


I was able to install influxdb 1.8 rpm on centos7
However, the configuration that i see in /etc/influxdb/influxdb.conf and influxdb config command differ. e.g. in the conf file flux-enabled is false, where as influxd config shows flux-enabled is true, there are several properties which differ, including http enabled etc. Also althoughth service starts, i am not able to see any service logs nor the web UI on 8086. Not sure how to find which config file it is using as there is only one influxdb.conf file.

You could try to run a Flux query.
I’m a little confused about your question.
When you say the InfluxDB CLI config do you mean:

The influxd service uses the config stored in /etc/influxdb/influxdb.conf.

As for longs I believe this still applies to 2.x

Thanks for response,

When i install rpm, it setup systemd unit file. Per unit file influxd is started with /usr/lib/influxdb/scripts/

BTW: i downloaded the rpm via

with the service started, I am not sure where this service keeps the logs, my /var/log/influxdb/ is empty.

by cli i mean running ‘influxd config’ command. The output shown by this command differs with content of /etc/influxdb/influxdb.conf file.

As far as UI is concerned, i can see port 9086 in use if I run netstat command but browser gives me 404 page not found.


uhmm weird part is

in the browser if query http://:8086/health?u=admin&p= then it returns JSON with status pass, version 1.8.10 but just host:8086 is 404 …uhmm

I updated my service per startup script stuck in while loop if http auth set · Issue #21967 · influxdata/influxdb · GitHub

still no UI