Influxdb 1.8.7 will not start

InfluxDB fails to start

sudo systemctl start influxdb.service

after installing:

influxdb-1.8.7.x86_64.rpm from https://repos.influxdata.com/rhel/7/x86_64/stable/influxdb-1.8.7.x86_64.rpm

…which seems to be last updated on 2021-07-28 21:09

I get the following error when I run journalctl -xe

-- Unit influxdb.service has begun starting up.
Jul 29 18:53:05 my-machine-name systemd[19040]: Failed at step EXEC spawning /usr/lib/influxdb/scripts/influxd-systemd-start.sh: Permission denied

When I run the following command

sudo chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh

…then the service starts.

Looks like a packaging problem.

1 Like

Hi new here(influxdb,Linux,raspberrypi etc). After update from 1.8.6-1 to 1.8.7-1 these a similar behaviour. i run journalctl -u influxdb and got these:

Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Service RestartSec=100ms expired, scheduling restart.
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Scheduled restart job, restart counter is at 3.
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: Stopped InfluxDB is an open-source, distributed, time series database.
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: Starting InfluxDB is an open-source, distributed, time series database…
Jul 29 22:59:26 TheRaspberrypi4 systemd[1551]: influxdb.service: Failed to execute command: Permission denied
Jul 29 22:59:26 TheRaspberrypi4 systemd[1551]: influxdb.service: Failed at step EXEC spawning /usr/lib/influxdb/scripts/influxd-systemd-start.sh: Permission denied
Jul 29 22:59:26 TheRaspberrypi4 systemd[1]: influxdb.service: Control process exited, code=exited, status=203/EXEC

I got it run(partially ) only by sudo influxd.

The issue here is likely that the InfluxDB service is typically run as the user “influxdb”. If you want to confirm, you need to see where your systemd startup configuration is set. Not sure about the raspian distro, but on the RHEL that user is specific in /etc/systemd/system/influxd.service.

If the service doesn’t start for you, it could be that when the user influxdb can’t execute /usr/lib/influxdb/scripts/influxd-systemd-start.sh, the permissions issue I mentioned above. But, since you can run influxdb when you start with sudo seems to confirm you have the same issue.

1 Like

it is the same path /etc/systemd/system/influxd.service and it is a symlink
to /lib/systemd/system/influxdb.service

[Service]
User=influxdb
Group=influxdb
LimitNOFILE=65536
EnvironmentFile=-/etc/default/influxdb
ExecStart=/usr/lib/influxdb/scripts/influxd-systemd-start.sh
KillMode=control-group
Restart=on-failure
Type=forking
PIDFile=/var/lib/influxdb/influxd.pid

Ran into this bug today. running it on raspi also
i chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh and services were able to be started
upgraded info influxdb:armhf (1.8.6-1, 1.8.7-1)

2 Likes

Happened after the latest upgrade on Debian Buster, worked ok for months, so what has changed, and was it tested?

chmod +x /usr/lib/influxdb/scripts/influxd-systemd-start.sh
worked, but not the correct solution(world r+x)

influx started failing again today. script is +x, so that’s not the issue now.
this is getting frustrating

should I just move on to 2.x?

are there any instructions on downgrading? i’ll just move back to 1.8.6

v2 has some major changes that you need to test/consider before you upgrade to it.

yes…unfortunately, i may just have to do a fresh install and move to 2 maybe. i can’t find 1.8.6 in the repos…wish they’d just keep the old packages available.

started getting this error now, runtime: out of memory: cannot allocate 81920-byte block (1252196352 in use) fatal error: out of memory
i’m not using inmem either. I have 4GB on my rasp pi, so I don’t think memory is really an issue. 1.8.7 has bugs

@aimdev, you are correct: it’s certainly messy at best.

In my case the influxdb user is a member of only the group influxdb. Since the script under question is delivered with a ownership of root:root, I chose to “go wide.” Naturally, you could/should adjust any recommendation to match your implementation, as YMMV.

I have no idea what’s going on.
I had rebooted my pi a few times and the service kept dying
I was going to install 2.0, but wanted to enable 64 bit support on the pi, so I added the arm_64bit=1
to the /boot/config.txt file
I restarted the pi and suddenly things are working just fine
I’m thoroughly confused as to what’s going on now

@influxian - your out of memory error error sounds like a different issue - I’m not a rPi user of InfluxDB, so can’t comment there.

Perhaps spin up a new thread so that others can find it and comment on it?

Hi there,

We are tracking the following two issues in 1.8.7 with the deb and rpm packages stemming from a wrapper script used for running in systemd:

Fixes are incoming (referenced in each respective bug) and we will be cutting a 1.8.8 release this week, with the recommended fix being to upgrade to the new version.

2 Likes

Hi,
so i did update to 1.8.9 but still not able to run as a service. Now the status of the service is inactive(dead).
When i run influxd i get run: open server: listen: listen tcp 127.0.0.1:8088: bind: address already in use
but i did not change something in my system since version 1.8.6 which was ok, again only with sudo influxd.

While reading another post, i tried to run sudo systemctl start influxdb and the service started!
now the folder /usr/lib/influxdb is owned by root, should be change to influxd as suggested by the post below?

still having issues in 1.8.9-1

1 Like

I am also running 1.8.9-1 and influxdb is not able to start
even with default configuration it does not come up
pi@raspberrypidns:/etc/influxdb $ systemctl status influxdb.service
● influxdb.service - InfluxDB is an open-source, distributed, time series database
Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)
Active: activating (start) since Sat 2021-08-07 10:56:20 CEST; 4s ago
Docs: InfluxDB OSS 2.0 Documentation
Cntrl PID: 17490 (influxd-systemd)
Tasks: 20 (limit: 1891)
CGroup: /system.slice/influxdb.service
├─17490 /bin/bash -e /usr/lib/influxdb/scripts/influxd-systemd-start.sh
├─17491 /usr/bin/influxd -config /etc/influxdb/influxdb.conf
└─17540 sleep 1

Aug 07 10:56:20 raspberrypidns systemd[1]: Starting InfluxDB is an open-source, distributed, time series database…
Aug 07 10:56:20 raspberrypidns influxd-systemd-start.sh[17490]: Merging with configuration at: /etc/influxdb/influxdb.conf
Aug 07 10:56:20 raspberrypidns influxd-systemd-start.sh[17490]: Merging with configuration at: /etc/influxdb/influxdb.conf

– Subject: A start job for unit influxdb.service has failed
– Defined-By: systemd
– Support: Debian -- Support

– A start job for unit influxdb.service has finished with a failure.

I spoke too soon. Service failed this morning and I haven’t looked into it, but I web’d into grafana and see Bad Gateway errors, which means influx is down, again.

Seriously, I may need to migrate to Prometheus or something else

Same problem here. 1.8.9-1
sudo systemctl start influxdb
Job for influxdb.service failed because the control process exited with error code.
See “systemctl status influxdb.service” and “journalctl -xe” for details.

sudo service influxdb status
● influxdb.service - InfluxDB is an open-source, distributed, time series database
Loaded: loaded (/lib/systemd/system/influxdb.service; disabled; vendor preset: enabled)
Active: activating (start) since Sat 2021-08-07 14:40:29 CEST; 4s ago
Docs: InfluxDB OSS 2.0 Documentation
Cntrl PID: 27537 (influxd-systemd)
Tasks: 14 (limit: 4915)
CGroup: /system.slice/influxdb.service
├─27537 /bin/bash -e /usr/lib/influxdb/scripts/influxd-systemd-start.sh
├─27538 /usr/bin/influxd -config /etc/influxdb/influxdb.conf
└─27585 sleep 1

Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.632481Z lvl=info msg="Ope
Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.634698Z lvl=info msg="Ope
Aug 07 14:40:29 raspberrypi4-iob influxd-systemd-start.sh[27537]: ts=2021-08-07T12:40:29.636942Z lvl=info msg="Ope