Influx will not start if data directory changed

influxdb

#1

Influx v 1.3.6
Ubuntu 17.04

  1. Installed influxdb . Up and running all good. Then, was going to load some real data so wanted to change the data directory to a larger drive.
  2. First attempt, edited /etc/influxdb/influxdb.conf and changed the data dir entry. Would not start.
  3. Second attempt, changed all three of the meta, data, and wall to where I wanted it. Still no dice.
  4. Went to the drive and location where I wanted the data to reside. I made the owner influxdb, so everything read
    influxdb:influxdb and also made sure the permissions and owner exactly matched those in the default data directory.

Still no dice. Influx will not start after I change the directory. Here’s where it is right now - I have two config files, the original, which will allow influxdb to start no problem. Then I have my custom one, with the three changes to change location. Influxdb will not start with that one.

Triple, quadruple checked all paths, permissions, and owners. What could I be missing?


#2

Replying to my own here - the issue is when you use a mounted drive. I can change locations to somewhere on my primary drive but as soon as I tried to use the second mounted hard drive, simply won’t start. I tried symbolic links over there, all kinds of things. There must be something to do with obscure settings suck as stick bit or ACLs or something.

If anybody has been through this before, would like to hear the solution.


#3

[SOLVED] Turns out that the path where the drive is mounted had a directory two levels upstream where the permissions where set as follows:
drwxr-x—

So, this actually made the directory unwriteable for the influxdb user downstream. I changed that directory to the following permissions:
drwxr-xr-x

This allowed the influxdb user/group to write downstream where I actually had the data paths set.


#4

Jeff,

can you please share you info here, I’m having exact same, I mounted my synology disk, the data meta and wall folders are created, though when trying to get influx command to work, it doesn’t work …

I got it mounted in /mnt/influxdb and there I got the 3 folders, tried renaming only 1 of them, separately, never works, I think my rights are correct though …


#5

2 things to check - first is the owner AND group set to influxdb on those directories? If not, you need to chown those for influxdb to be user and group owners. Second thing is to check the permissions of that directory all the way back up and make sure permissions are set right. See my post from October 29th in this chain.


#6

I found out some other script was still running, and therefore messed up the change of locations, got it solved

thanks for the help though