How to write data to InfluxDB v2.0

#1

I configured my Telegraf client but no data is written to the InfluxDB. I also tried to directly write to the influxdb v2 with /write or /query, different Telegraf configs with input didn’t work either. Any help?

I do get a telegraf 20X response which is good. It just doesnt get written to the DB.

# Configuration for telegraf agent
[agent]
  ## Default data collection interval for all inputs
  interval = "10s"
  ## Rounds collection interval to 'interval'
  ## ie, if interval="10s" then always collect on :00, :10, :20, etc.
  round_interval = true

  ## Telegraf will send metrics to outputs in batches of at most
  ## metric_batch_size metrics.
  ## This controls the size of writes that Telegraf sends to output plugins.
  metric_batch_size = 1000

  ## For failed writes, telegraf will cache metric_buffer_limit metrics for each
  ## output, and will flush this buffer on a successful write. Oldest metrics
  ## are dropped first when this buffer fills.
  ## This buffer only fills when writes fail to output plugin(s).
  metric_buffer_limit = 10000

  ## Collection jitter is used to jitter the collection by a random amount.
  ## Each plugin will sleep for a random time within jitter before collecting.
  ## This can be used to avoid many plugins querying things like sysfs at the
  ## same time, which can have a measurable effect on the system.
  collection_jitter = "0s"

  ## Default flushing interval for all outputs. Maximum flush_interval will be
  ## flush_interval + flush_jitter
  flush_interval = "10s"
  ## Jitter the flush interval by a random amount. This is primarily to avoid
  ## large write spikes for users running a large number of telegraf instances.
  ## ie, a jitter of 5s and interval 10s means flushes will happen every 10-15s
  flush_jitter = "0s"

  ## By default or when set to "0s", precision will be set to the same
  ## timestamp order as the collection interval, with the maximum being 1s.
  ##   ie, when interval = "10s", precision will be "1s"
  ##       when interval = "250ms", precision will be "1ms"
  ## Precision will NOT be used for service inputs. It is up to each individual
  ## service input to set the timestamp at the appropriate precision.
  ## Valid time units are "ns", "us" (or "µs"), "ms", "s".
  precision = ""

  ## Logging configuration:
  ## Run telegraf with debug log messages.
  debug = false
  ## Run telegraf in quiet mode (error log messages only).
  quiet = false
  ## Specify the log file name. The empty string means to log to stderr.
  logfile = ""

  ## Override default hostname, if empty use os.Hostname()
  hostname = ""
  ## If set to true, do no set the "host" tag in the telegraf agent.
  omit_hostname = false
[[outputs.influxdb_v2]]	
  ## The URLs of the InfluxDB cluster nodes.
  ##
  ## Multiple URLs can be specified for a single cluster, only ONE of the
  ## urls will be written to each interval.
  urls = ["XXXXXXXXXXX:9999"]

  ## Token for authentication.
  token = "$INFLUX_TOKEN"

  ## Organization is the name of the organization you wish to write to; must exist.
  organization = "alstom"

  ## Destination bucket to write into.
  bucket = "telemetry"
[[inputs.cpu]]
  ## Whether to report per-cpu stats or not
  percpu = true
  ## Whether to report total system cpu stats or not
  totalcpu = true
  ## If true, collect raw CPU time metrics.
  collect_cpu_time = false
  ## If true, compute and report the sum of all non-idle CPU states.
  report_active = false
[[inputs.disk]]
  ## By default stats will be gathered for all mount points.
  ## Set mount_points will restrict the stats to only the specified mount points.
  # mount_points = ["/"]
  ## Ignore mount points by filesystem type.
  ignore_fs = ["tmpfs", "devtmpfs", "devfs", "overlay", "aufs", "squashfs"]
[[inputs.diskio]]
[[inputs.mem]]
[[inputs.net]]
[[inputs.processes]]
[[inputs.swap]]
[[inputs.system]]

[[inputs.influxdb_listener]]
  ## Address and port to host HTTP listener on
  service_address = ":9998"

  ## Path to listen to.
  #path = "/write"

  ## HTTP methods to accept.
  #methods = ["POST", "PUT"]

  ## maximum duration before timing out read of the request
  read_timeout = "10s"
  ## maximum duration before timing out write of the response
  write_timeout = "10s"

  ## Maximum allowed http request body size in bytes.
  ## 0 means to use the default of 524,288,000 bytes (500 mebibytes)
  max_body_size = 0
  max_line_size = 0 
  ## Set one or more allowed client CA certificate file names to
  ## enable mutually authenticated TLS connections
  # tls_allowed_cacerts = ["/etc/telegraf/clientca.pem"]

  ## Add service certificate and key
  # tls_cert = "/etc/telegraf/cert.pem"
  # tls_key = "/etc/telegraf/key.pem"

  ## Optional username and password to accept for HTTP basic authentication.
  ## You probably want to make sure you have TLS configured above for this.
  #  basic_username = "foobar"
  #  basic_password = "barfoo"

  ## Data format to consume.
  ## Each data format has its own unique set of configuration options, read
  ## more about them here:
  ## https://github.com/influxdata/telegraf/blob/master/docs/DATA_FORMATS_INPUT.md
  #data_format = "influx"
#2

Hi @samvruggink, what version of Telegraf are you using? You will need version 1.9.2 or higher.

#3

I am using V1.10. It seems to work correctly but there is no way I am able to get my data in influxv2. Even with the /write endpoint direct on influxdb itself. Gives me a 20X response and nothing else. Mmm.

#4

What response do you get when you try to use the /write endpoint?

#5

Sorry, just saw you said a 20X response. I’ll check in with the Alpha team to see what they think.

#6

One thing it would be good to try is to see if you can write to the db using line protocol in the browser using the add data function. That way we can start to diagnose where the problem lies.

#7

I got success messages only, still cannot view any data.

Docker:
docker run --name telegraf -e INFLUX_TOKEN -v /home/alstom31337/conf/telegraf.conf:/etc/telegraf/telegraf.conf:ro telegraf
docker run --name influxdb -p 9999:9999 quay.io/influxdb/influxdb:2.0.0-alpha

#8

#9

sorry for the spam but I cannot include more than one images per post. :wink:
btw thanks for the help. :smiley:

#10

Can you try writing a data point without a time stamp?

#11

That seems to work yes. I will now try it with telegraf.

#12

The reason I asked you to write data without a timestamp is because you can’t see data in the query builder that is older than 30 days, so I just wanted to be sure you could write to the db at all, which it looks like you can. The problem is not having the timestamp itself, just that in the UI you can’t see older data in the builder although you can query that older data in the script editor.

1 Like
#13

So it worked the first time as well… Didn’t know this. Happy that it works again and thank you so much! I really enjoy using influxdata products and besides this small error I made, I absolutely love it!

Thanks!

#14

Awesome! Glad it worked.