How to exploit the UCD-SNMP-MIB laLoad table with the TIG stack?

grafana
telegraf
influxdb
#1

Hi,
I use the Telegraf InfluxDB Grafana Stack.
I work with the UCD-SNMP-MIB and I can Exploit almost each OID except the Load Average.
In the MIB this metrics “loadaverage” are under the laTable (.1.3.6.1.4.1.2021.10) with the laLoad OID (.1.3.6.1.4.1.2021.10.1.3).
The problem is that this oid returns the three values (1, 5, 15 minutes load average). So I tried the three OID :

  • Load 1 : .1.3.6.1.4.1.2021.10.1.3.1
  • Load 5 : .1.3.6.1.4.1.2021.10.1.3.2
  • Load 15 : 1.3.6.1.4.1.2021.10.1.3

I can see these values in InfluxDB but I can’t display them (no data) on Grafana.
So I thought “may be it is because we have a table in a table and we can’t manage this case”…

Did someone tried to exploit load average with snmp ?

Thank you for your help !

Edit : for the understanding I post a screenshot of the OID I can’t can’t see :

As you can see the 3 load values are in the same table.
The format seems to be “string” could it be a problem ?

#2

Can you share the configuration you are currently trying to use?

#3

Hi,
I have some news that I’ll try to explain.

Now I can get the load average from the UCD-SNMP-MIB, but only the Int values (percentage).

What I did for that :

1- My conf (input SNMP):

[[inputs.snmp]]
agents = [ “XXX.X.X.X:161” ]

timeout = “5s”
retries = 3
version = 2
community = “public”

name = “test”

[[inputs.snmp.field]]
name = “memTotalFree”
oid = “.1.3.6.1.4.1.2021.4.11.0”

[[inputs.snmp.field]]
name = “cpu_percent”
oid = “.1.3.6.1.4.1.2021.11.9.0”

[[inputs.snmp.field]]
name = “Ram_Used”
oid = “.1.3.6.1.4.1.2021.4.6.0”

[[inputs.snmp.table]]
#measurement name
name = “la_Table_I”
#inherit_tags = [ “” ]
oid = “.1.3.6.1.4.1.2021.10”

#[[inputs.snmp.table.field]]
#name = “load1-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.1”
#[[inputs.snmp.table.field]]
#name = “load5-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.2”
#[[inputs.snmp.table.field]]
#name = “load15-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.3”
#is_tag = true


2- Explanation :

I’ve declared the laTable “.1.3.6.1.4.1.2021.10” :

[[inputs.snmp.table]]
name = “la_Table_I”
oid = “.1.3.6.1.4.1.2021.10”

3- In Grafana I have the measurement “la_Table_I” and I can choose laindexes 1, 2, 3 wich refers to load1, load5 and load15 :

I can choose the values in the table (laConfig …laLoad, laLoadInt …) :

4- Some remarks :

  • I only can graph the laLoadInt, no other field from this table…

  • Furthermore, some fields are missing from this table if you compare to what the UCD-SNMP-MIB offers (look at my first screenshot ) for instance, laLoadFloat doesn’t appear.

  • I just had to add the snmp table, I tried with other OID as you can see in commentaries at the end of the telegraf conf, but this didn’t work.