Grafana stops receiving vsphere datastore metrics

I am using the vsphere plugin and have a dashboard in Grafana similar to this (capacity summary widget) where my datastore metrics are displayed. Recently, after updating telegraf to 1.10.0 I started to notice that after a while, the dashboard would be empty. A simple restart of telegraf doesn’t fix the issue but if I go and uncomment

## Datastores
 datastore_metric_include = [] ## if omitted or empty, all metrics are collected
# datastore_metric_exclude = [] ## Nothing excluded by default
# datastore_instances = false ## false by default for Datastores only

and restart telegraf, it starts working again but only briefly. After a while, it stops again so I will go back and now this time, comment

#  datastore_metric_include = [] ## if omitted or empty, all metrics are collected

and restart and the metrics are restored but again, only briefly. I am not sure if this is a bug since my skill level doesn’t allow me to further troubleshoot and send in a bug report.

I’ve been using this dashboard for quite some time and only after the update I noticed this behavior.

Any help would be greatly appreciated.

Grafana v6.0.1
InfluxDB shell version: 1.7.4

Did you use the Vsphere input plugin with Telegraf 1.9.x?

I know they updated one of the metrics from float to int which will break things.
I would turn on debug in your telegraf.conf and restart it. Watch the logs and see what it says

may I know how you solved the issue? I am having the exact same issue with telegraf 1.12.5, the datastore metrics work for a while and then stop working.


I ended up collecting only the metrics I was interested in and somehow that solved the issue. I think it had something to do with this but I am not sure.

This is what works for me:

  ## Datastores
   datastore_metric_include = [