Fresh Installation fails onboarding

Hi, I have a Raspebrry Pi 4B in a Geekworm case, using a Kingston SSD for boot and storage. I flashed the SSD with the latest Raspberry Pi OS (64bit). Once booted up, I SSHd through and used the commands from Downloads ( to install Influxdb2. The commands I used were:

wget -q

echo '393e8779c89ac8d958f81f942f9ad7fb82a25e133faddaf92e15b16e6ac9ce4c influxdata-archive_compat.key' | sha256sum -c && cat influxdata-archive_compat.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg > /dev/null

echo 'deb [signed-by=/etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg] stable main' | sudo tee /etc/apt/sources.list.d/influxdata.list

sudo apt-get update && sudo apt-get install influxdb2

sudo systemctl unmask influxdb.service

sudo systemctl start influxdb

I then rebooted the Pi, SSHd back in and ran

sudo service influxdb status

which returned

influxdb.service - InfluxDB is an open-source, distributed, time series database
     Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2023-09-08 10:49:30 BST; 11s ago
    Process: 7082 ExecStart=/usr/lib/influxdb/scripts/ (code=exited, status=0/SUCCESS)
   Main PID: 7083 (influxd)
      Tasks: 9 (limit: 8754)
        CPU: 1.320s
     CGroup: /system.slice/influxdb.service
             └─7083 /usr/bin/influxd

Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.595195Z lvl=info msg="Open store (star>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.595362Z lvl=info msg="Open store (end)>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.595443Z lvl=info msg="Starting retenti>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.595478Z lvl=info msg="Starting precrea>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.597763Z lvl=info msg="Starting query c>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.606146Z lvl=info msg="Configuring Infl>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.622726Z lvl=info msg=Starting log_id=0>
Sep 08 10:49:29 pi-server[7083]: ts=2023-09-08T09:49:29.623439Z lvl=info msg=Listening log_id=>
Sep 08 10:49:30 pi-server[7082]: InfluxDB started
Sep 08 10:49:30 pi-server systemd[1]: Started InfluxDB is an open-source, distributed, time series database.

I then went to http:IP_ADDRESS:8086 and started the onboarding process but cannot create the initial admin user

I’ve followed this process twice, with the same result. What am I doing wrong?

I think this is something to do with permissions? If I enter

influx auth list

I get
Error: could not find authorization with given parameters: 401 Unauthorized: unauthorized access

How do I correct the permissions?

Hello @GwelforBodad,
This is super weird you should first set up your first auth with the UI when you first install. Can you please try uninstalling and reinstalling?

Hi @Anaisdg,
I’ve tried this four times now. I start with a blank SSD, write the 64-bit PiOS to it. Install it into the Pi, do the update/upgrade, then the installation of Influxdb per the instructions, all using SSH. Every time, it fails to allow me to create the admin user from the UI. Any ideas?


I used the same instructions on another Pi about two weeks ago and that’s working fine. One of the installations was onto a USB stick with the same result. I just wonder what’s changed in the last couple of weeks?

I installed Ubuntu Server 20.04.3 LTS (64-bit) using the Pi imager. Then followed the installation instructions referred to above and still can’t create the first auth from the UI.

I’ve finally worked out what the problem is! The advice on passwords includes special characters, for example


.The advice recommends wrapping the password in double quotes if it includes these characters. I assumed that double quotes were only necessary on the command line and that entering the £ symbol in the password dialog during onboarding would not cause a problem. Avoiding any special characters does now enable me to complete onboarding, but it would have been useful to either be explicit about requiring double quotes, even in the onboarding dialog, or at least know that this can be an issue for anyone attempting the onboarding process.