Edge Data replication, How to find out a solution with Error: 502 notresolvable: unable to decode response content type "text/html"

I’m starting to use Edge Data replication.
at the moment testing the local network between InfluxDB OSS and InfluxDB OSS.
Several PCs work well without problem. but one of the PCs is not well with Error 502.

those PC running on Windows10 Pro (21H2)
Influxdb Version 2.3
influx CLI 2.3

those PCs running the same network.

I checked firewall anti-virus settings(even tested disable), confirmed DNS(refreshed), and Gateway settings all the same.

But one of the PCs does not communicate replication with the server.
but I can access the web interface port 8086, windows ping also works.
to find out the issue I use influx.exe to confirm ping. I get the following error message.

PS C:\Program Files\InfluxData\influxdb2-client> .\influx.exe ping
Error: 502 notresolvable: unable to decode response content type
“text/html”

I checked network traffic using Wireshark.
When applying ping, only the packet appears on localhost, not on the ip address of the server.
I believe the issue came from the PC setting.
Do you have any suggestions for those error messages?

Hello @Yutaka,
Welcome!
You can only replicate from OSS to Cloud:

You can use tasks and the to() function to write data from OSS to OSS:

Hello
Thank you for your informaiton.
I understand replication for OSS to Cloud.

I followed the instruction of to() method. but still not able to send data.
from Data Explorer

from(bucket: “mybucket”)
|> range(start: v.timeRangeStart, stop: v.timeRangeStop)
|> filter(fn: (r) => r[“_measurement”] == “mydata”)
|>to(host: “http://myhttphostname:8086”, orgID: “myorgid”, token: “mytoken”, bucketID: “mybuketid”)

Press “SUBMIT”, without error message. but still not data to server.
but I tried other PC(which worked replication), it works fine.

Do you know how to confirm resolut of SUBMIT. exsample:error or success of to().

Screen Shot 2022-08-24 at 12.00.45 PM
You should see the execution time here on the tab.

You can also try a cURL request:

Hello @Anaisdg

Thank you for your information.
When using cURL, I was able to see error details.
Finally found a solution.
Problems come from proxy settings on Environment variables of Windows10
This system also installed Grafana.
I added a proxy address in Environment variables for internet connection.
because Proxy setting on Network & Internet does not help.

HTTP_PORXY http://*****:80

HTTPS_PORXY http://*****:80

When I remove those settings, I can able to communicate with all PCs.
Strange thing, some PCs have the same setting, but are able to communicate.
it will be windows things.

I’m sorry, I made a problem myself. :face_with_spiral_eyes:
Thank you very much for your support. :grinning:

Hello @Yutaka,
I’m so sorry. I was so wrong. You absolutely can replicate from OSS to OSS with Edge Data Replication. I was just confused because the examples in the docs are OSS → Cloud (I’m working on a PR/issue).

Here’s an example of OSS → OSS or edge to edge:

@Jay_Clifford have you seen the error:

PS C:\Program Files\InfluxData\influxdb2-client> .\influx.exe ping
Error: 502 notresolvable: unable to decode response content type
“text/html”

with edge to edge before?

Hello @Anaisdg .
Thank you for your information.
No problem.

I confirmed with OSS to OSS works fine with Edge Data Replication, after change proxy setting.
cURL method with to() helped for understand problem where come from.

Thank you again.:smile:

1 Like

@Yutaka,
Of course!
I’m sorry about the confusion again.

1 Like