InfluxDB2 CLI - error message (... 404 Not Found: unable to decode response content type "text/html; charset=iso-8859-1)

I’m a newbie with Influxdb.

My intention is to switch from a MySQL database to Influxdb on my QNAP 451+ for storage of different measurements, e.g. coming from the photovoltaic system.

I started with different docker containers and used “latest” so I got influxdb2 2.6.1 release.

Independently what I tried, influxDB2 itself was running, I can access WEB-frontend via port 8086, I can select measurements, create buckets a.s.o.

The problem is with the “cli”. Starting “cli” in docker environment what ever I try, I get an error message

../# influx user list
Error: failed to list users: 404 Not Found: unable to decode response content type "text/html; charset=iso-8859-1"

Then I tried to install a qpkg-package instead of using docker container (many thanks to the MyQnap-team for providing a separate package with cli).

Result is the same → influxDB2 is running, behavior of “cli” still the same, absolutely identical error message.

I have no more idea, what could be the reason for that issue. And yes, I have seen an issue in github but no comment there.

Many thanks in advance for any hint

Hello @jrgsch,
Have you seen the following tutorial?

It might be useful to you.