Dropping a measurement with special symbols in the name

Version “1.8.9”
I have some trash measurements with autogenerated names, for example:

*** Element info: {Using=id, value=//*[@id=“__next”]/div[2]/main/div/div/div/div[2]/div[1]/div/div}

I’ve tried to drop it with escaping characters

DROP MEASUREMENT “*** Element info: {Using=id, value=//*[@id="__next"]/div[2]/main/div/div/div/div[2]/div[1]/div/div}”
Success! (no results to display)

but the measurement is still persisting.

Adding escaping slash to spaces and asterisks causes output error:

DROP MEASUREMENT “***\ Element\ info:\ {Using=id,\ value=//*[@id=“__next”]/div[2]/main/div/div/div/div[2]/div[1]/div/div}”
Server returned error: error parsing query: found *, expected identifier at line 1, char 18

Could you kindly help me to solve this, please
Many thanks, have a lovely day!

Hello @Rumata,
Is this problem still persisting? Sometimes it takes some time for the WAL to reach eventual consistency or delayed deletion can be the result of processing time between shards and their compaction.

And I apologize I feel dense.
What is the difference between the two commands you tried?
Aside from the message returned?
Also in the future it’s a good idea to keep your measurement names simple :slight_smile: Both to make querying easier and more performant.

Hi, @Anaisdg,

Thank you very much for your response!

Sorry, there was a mistake in my copy-pasting. I’ve corrected it, so now the second command is accurate.
upd. Is not. The text editor swallows some symbols again. Trying without quoting:

DROP MEASUREMENT “\*\*\*\ Element\ info:\ {Using=id,\ value=//\*[@id=\"__next\"]/div[2]/main/div/div/div/div[2]/div[1]/div/div}”

Server returned error: error parsing query: found *, expected identifier at line 1, char 18

Recently, I deleted some unused measurements, so they were dropped quickly. However, these incorrect measurements are still persisting.

Your advice is perfect :slight_smile:, but as you can see, the namings were generated by some buggy code, not by someone like me :beetle:

Many thanks for your assistance, have a great day!

Of course! Just to check is this still persisting? I’m not sure.

Just checked one more time, the measurement is still persisting. Other ones (with correct namings) are dropping immediately.