Disable Influxd logging

Hi,

I use grafana to monitor our system, and influxdb as datastore. I disabled Influxdb http logging in the config file:

[http]
  # Determines whether HTTP endpoint is enabled.
  # enabled = true

  # The bind address used by the HTTP service.
  # bind-address = ":8086"

  # Determines whether HTTP authentication is enabled.
  # auth-enabled = false

  # The default realm sent back when issuing a basic auth challenge.
  # realm = "InfluxDB"

  # Determines whether HTTP request logging is enable.d
  log-enabled = false

  # Determines whether detailed write logging is enabled.
  write-tracing = false

Restarted influxd service and I refresh grafana page, the logging was still shown in syslog

Mar 31 16:46:20 lknode53 influxd[11144]: [I] 2017-03-31T08:46:20Z SELECT last(used) / last(total) AS mem_used FROM telegraf.autogen.mem WHERE time > now() - 1h GROUP BY time(2s), host ORDER BY ASC service=query
Mar 31 16:46:40 lknode53 influxd[11144]: [I] 2017-03-31T08:46:40Z SELECT elapsed(last(system), 1s) FROM telegraf.autogen.erlang_memory WHERE time > now() - 5m GROUP BY time(200ms), * ORDER BY ASC service=query
Mar 31 16:47:01 lknode53 influxd[11144]: [I] 2017-03-31T08:47:01Z SELECT last(used) / last(total) AS usage FROM telegraf.autogen.disk WHERE time > now() - 1m GROUP BY time(50ms), host, path service=query
Mar 31 16:47:20 lknode53 influxd[11144]: [I] 2017-03-31T08:47:20Z SELECT elapsed(last(system), 1s) FROM telegraf.autogen.erlang_memory WHERE time > now() - 5m GROUP BY time(200ms), * ORDER BY ASC service=query
Mar 31 16:47:20 lknode53 influxd[11144]: [I] 2017-03-31T08:47:20Z SELECT last(used) / last(total) AS mem_used FROM telegraf.autogen.mem WHERE time > now() - 1h GROUP BY time(2s), host ORDER BY ASC service=query

What should I do to disable the logging or redirect the log to another file? Thanks

-Jack

@jacktang To disable query logging set the following configuration parameter:

[data]
  query-log-enabled = false
1 Like

Thanks! It works now :slight_smile: