Logging messages in InfluxDB

influxdb
#1

Hi,

I’m running influxdb1.6.3, telegraf 1.8.0 on RHEL 7.4 on my clients. Seems that Influxdb spams my /var/log/messages file with hundreds (if not thousands) of messages based on the collection times of the influx configuration. How do I turn them off?

Seems like there’s a number of posts here and in GitHub (#1006/#8319) that relate to this but shouldn’t the system install with all except very basic logging (e.g. error) turned off?

The documentation seems confusing talking about [http] logging and by default to /var/log/influxdb/influxd.log when running as a service, but that certaining doesn’t happen on my boxes.

I need to install InfluxDB onto a number of system and would like to do this automatically, using Puppet, rather than having to configure each machine separately.

Having got a successfully running system, i now have machines that are clogged with messages. Please advise.

TIA
Martin

#2

Hi , if the logging comes from telegraf you can specify the logfile in the telegraf.conf file to avoid
that the logging goes to /var/log/messages

logfile = “/tmp/telegraf.log”;

If it comes from influxdb you can disable logging in the following sections of the influxdb.conf file

[continuous_queries]

log-enabled = false

[http]

log-enabled = false

best regards ,

#3

Thanks Marc. I’d found the [http] log-enabled and set it to false but didn’t know about the [continuous_queries] one. Still being a nob at this, I was just surprised that it was set to log everything from installation - rather than letting the user set them to true when things go wrong :blush:

When exactly does the [continuous_queries] section come into play?

Cheers

#4

Ah found the answer to my own question! :+1: Continuous_queries is for the queries behind the various panel that require input from the client via influx.

1 Like