Data corruption in InfluxDB in 1.8.5 with multiple UDP senders

We have an InfluxDB 1.8.5 server listening on a UDP port. Data is sent by two independent senders (Data acquisision MCUs) on the same subnet. Each is sending >1000 measures per second.

When either MCU is sending data, it is received fine. When both MCUs are sending data, the values are being corrupted.

We have tried creating two different databases on different ports but we still get the issue. The issue is not in the network layer because it works fine if both MCUs are sending but InfluxDB is only listening to one.

Does anyone have any suggestions on where we should look to try and resolve this issue?


Do have a raw pcap you’d be willing to share showing a normal input stream, compared with one where both are running and data is getting corrupted?

We spent a lot of time studying the raw packet data and discovered that the problem is not in Influx. The data is corrupted in the Ethernet packets before being loaded to Influxdb. We found that we could reduce the corruption using UDP unicast rather than broadcast so it seems to be related to the amount of network traffic at the MCU.