Use UDP on Windows Influx

#1

Hey, so I wanna send data into an influxdb from my arduino. UDP works on arduino end and i can receive UDP packages on my pc with a UDP receiver. But I cant get it to work, so UDP goes into influx. I enabled the UDP in config and made the appropriate changes shown in the tutorial given by influx. It feels like making changes in the config has no impact on the db and UDP never enables. I tried changing http settings, enabled= false and changed the port, but it still worked on the same port as before. Can someone help me?

1 Like
#2

Give us more detail - show us exactly what changes you made to the
configuration file and how you restarted Influx to use the new settings.

Regards,

Antony.

#3

So I have 2 executables, influxd and influx. I closed both windows, (i guess it closes influx too?). I opened the influxdb config via notepad and made changes to [[udp]] to enable it.(i removed the # at the begginging of the lines, they are supposed to be comments).Then i started the influxd executable again and started influx executable afterwards, send an UDP packet with line protocol shown in many tutorials, but no data is send to my Influx and cant be seen anywhere.

#4

[[udp]]
enabled = true
bind-address = “:8888”
database = “udp”
retention-policy = “”

InfluxDB precision for timestamps on received points ("" or “n”, “u”, “ms”, “s”, “m”, “h”)

precision = “s”

These next lines control how batching works. You should have this enabled

otherwise you could get dropped metrics or poor performance. Batching

will buffer points in memory if you have many coming in.

Flush if this many points get buffered
batch-size = 5000

Number of batches that may be pending in memory

batch-pending = 10

Will flush at least this often even if we haven’t hit buffer limit

batch-timeout = “1s”

UDP Read buffer size, 0 means OS default. UDP listener will fail if set above OS max.

read-buffer = 0

#5

Hopefully someone who knows about Windows can tell you the command to find out
whether Influx is listening on UDP port 8888 as a result of that.

I know how to do it on Linux (netstat -plun) but I don’t know what the Windows
command is.

Antony.

#6

Could this be a Windows firewall issue?

Can you disable it and try?

#7

Thanks for helping but i got the solution, i had to start influd.exe with the windows cmd console using influxd.exe -config influxdb.conf.