Configuration of telegraf.conf for an Azure InfluxDB Enterprise install

Hi, I am working with the new InfluxDB Enterprise component available in Azure Marketplace.

It was easy to install…so easy that I really do not understand the underlying networking of it.

I’d like to configure telegraf.conf’s [[outputs.influxdb]] section appropriately for this Azure install.

I need an entry in telegraf.conf like this:
## The full HTTP or UDP URL for your InfluxDB instance.
## Multiple URLs can be specified for a single cluster, only ONE of the
## urls will be written to each interval.
urls = [“unix:///var/run/influxdb.sock”]

…but it is a complete mystery to me what the appropriate URL is for this Azure install.

Thanks for any guidance

Nothing changes, you have to provide the usual influxDB URL (probably it uses the default port 8086 for influxdb 1.x…)
http://<hostname or IP>:port (or https)

You might need to allow communication through the firewall for it to receive/send data (at least in my azure experience, but I’m using a standard VM)

Thanks for the helping hand, Giovanni.

I believe my first problem was understanding which VM in my InfluxDB Enterprise install was the correct one to use for the [[outputs.influxdb]] config in telegraf.conf.

I believe the load balancer is the right one. In my Azure install, the load balancer front-end (LBFE) has a private IP, So I now have this in telegraf.conf
urls = [“”]

…and I am now seeing activity in /var/log/telegraf/telegraf.log. In other words log entries seem to appear synchronously with measurement writing attempts. I think telegraf.conf is good now

But I believe I have some networking problem now, writing attempts are failing and timing-out:

2020-11-11T17:08:51Z E! [agent] Error writing to outputs.influxdb: could not write any address
2020-11-11T17:08:56Z W! [outputs.influxdb] When writing to [ht_p://]: database “cdr” creation failed: Post ht_p:// net/ht
tp: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)
2020-11-11T17:09:01Z W! [agent] [“outputs.influxdb”] did not complete within its flush interval
2020-11-11T17:09:01Z D! [outputs.influxdb] Buffer fullness: 1670 / 10000 metrics
2020-11-11T17:09:01Z E! [outputs.influxdb] When writing to [ht_p://]: Post net/http: request canceled whil
e waiting for connection (Client.Timeout exceeded while awaiting headers)

This may be the firewall problem you were anticipating :slight_smile:
I will continue to debug. This was a plain vanilla installation of InfluxDB Enterprise from the Azure Marketplace; I was hoping for a more plug-and-play experience. If anyone has had these problems before and cares to share, thank you in advance.

I solved this one. I created a new instance of Azure InfluxDB Enterprise, this time specifying an external load balancer IP instead of an internal one. I can’t say with certainty that this solved my problem–there is a chance I had some misconfiguration somewhere that was resolved by the fresh install.

Once I configured the [[inputs.eventhub_consumer]] section with the EventHub connection string and the [[outputs.influxdb]] with the public IP of the load balancer, the connectivity was established.

1 Like