Chronograf opening up TCP connection to Heroku IP address

I’m trying out chronograf and I’ve noticed that it’s opening up a TCP connection to a different IP address every time I restart it. The IP address always routes to a Heroku page that says “There’s nothing here, yet”. Is this expected behavior? I’m very surprised with its default config to find it reaching out to an external address.

I used the latest debian package to install chronograf and simply started the service. This is Debian Wheezy.

@Kyle_Ames Its reporting some anonymous usage statistics to our reporting service. You can see some details in the following links:

You can disable this behavior by setting the REPORTING_DISABLED=true environmental variable.

Thanks for the fast and thorough reply! I remember now that InfluxDB does the same thing. I should have looked closer at the runtime arguments, oops! Thanks again for your time!!

1 Like

It’s not documented anywhere except here thanks to you asking the question! Thank you for reaching out!